Community discussions

 
webix
just joined
Topic Author
Posts: 13
Joined: Fri May 04, 2018 3:34 pm

Active BGP Routes not working

Thu Dec 06, 2018 2:47 pm

Hello Folks.

I recently installed a Mikrotik router on a IX (Identified by MK_IX) to do traffic interchange with my router on my facility (Identified by MK_local).

- I have configured the BGP sessions on the MK_IX like the IX provided me and the sessions are up and running. I receive ~200 routes.
- The MK_local already has other BGP sessions with other operators. They are working perfectly well and i can announce the public IPs correctly.

- I have set a GRE session between MK_IX and MK_local with private IPs (10.0.1.2 and 10.0.1.1 respectively).
- On MK_local i can ping MK_IX and vice versa without problems.
- I setup a BGP session between MK_IX and MK_local with my public ASN and the session is up and running.

Now my problems:
- On MK_IX, the only way to get the networks from MK_local announced is by selecting "Redistribute other BGP" on the instance for the IX.
- Also, i can only distribute the IX networks to MK_local if i select "Redistribute other BGP" on the BGP session for the MK_local.
- The MK_local successfully get the IX networks, he show them "Dynamic, Active and BGP", but i can't perform any traceroute or ping to these networks.

I have looked here on the forum and also on internet for a way to correctly configure a router on a IX but i can't find.
Someone can help me out on this?

Who is online

Users browsing this forum: No registered users and 37 guests