Community discussions

MikroTik App
 
iron4umx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Wed Jan 10, 2007 8:49 am
Location: Mexico

--- RouterOs 2.9.40 Hotspot + transparent web-proxy ---

Fri Mar 02, 2007 7:49 pm

Hello, I am triyin to use transparent web proxy for the hotspot clients.

I redirected the trafic from port 80 to the web-proxy port on chain pre-hotspot (This is the only thing that would work), but after this configuration is done, when I log out of the hotspot and try to log in, the login page would not appear.

I have allso tried to exclude the ip on witch the hotspot is running (! x.x.x.x) but it doesnt hellp.

Does anyone knows how to do this??

I understand why this is happening, but I don't know how to fix it. Please Hellp.
Independet Researcher and Developer for WIFI Telecomunications
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6624
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Sat Mar 03, 2007 5:13 pm

HotSpot provides transparent proxy feautre by itself, if you wish to log visited web-pages, add 'topic=webproxy' to 'system logging' with the required action.
 
iron4umx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Wed Jan 10, 2007 8:49 am
Location: Mexico

Tue Mar 06, 2007 6:50 am

Yes, I can see in Winbox for the user-profile that it has a transparent proxy option, but witht his option enabled or disabled, I can't see any difference or improvements when I oppen the same web page twise.

In the other hand If I use the web-proxy feature, I can see a really great improvement in the speed at witch the web pages oppen.

Like for an instance in the Web-Proxy feature, I can look at the numbers in the monitor, they move when I open the same web page, but if I trie to use the Web-Proxy feature in conjunction with the Hotspot, the only way for me to get it to work is to use a redirect rule from port 80 to the Web-Proxy port using chain: pre-hotspot, but if I use this rule, when a user tries tog in to the hotspot, the request are redirected to the Web-Proxy (and since the user is not validated yet in the hostpot, the user gets an error page) and not to the log in web page were you put your username and password.

Can I actually use Web-Proxy (Squid) and hotspot at the same time??
Independet Researcher and Developer for WIFI Telecomunications
 
amity2kare
newbie
Posts: 35
Joined: Tue Feb 13, 2007 4:24 pm
Location: INDIA

Hotspot + Web-Proxy

Wed Mar 07, 2007 11:38 am

Try setting the dst-nat rule in the hotspot chain (above the jump chain rules) instead of the pre-hotspot chain. I did that and it solved the problem.[/quote]
 
iron4umx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Wed Jan 10, 2007 8:49 am
Location: Mexico

Thu Mar 08, 2007 1:55 am

Hello amity2kare yes, you are rigth¡¡¡ I solved the problem following your advice, Thank you a lot¡¡¡

:D
Independet Researcher and Developer for WIFI Telecomunications
 
moi
just joined
Posts: 3
Joined: Tue Mar 20, 2007 9:53 am

Tue Mar 20, 2007 10:03 am

can u give the command?
 
iron4umx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Wed Jan 10, 2007 8:49 am
Location: Mexico

Fri Mar 23, 2007 11:21 pm

Hi, I did not use command line to do this, I used winbox, I solved the problem implementing this:

get your web-proxy up and running set it up to transparent mode, then in the firewall you redirect the trafict from port 80 to the port of the web-proxy and you use chain: hotspot.

There is documentation to set up transparent web-proxy, but if you whant to use this for the hotspot you have to change the chain to hotspot, the rest remains the same.

thats all there is to it¡¡¡

Best Regards

James S.
 
iron4umx
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Wed Jan 10, 2007 8:49 am
Location: Mexico

Re:

Thu Jul 19, 2007 8:58 am

can u give the command?
Shure¡¡¡ sorry I took so long, I did not know how to use the Command line before, now I know :D
 chain=hotspot action=redirect to-ports=3128 in-interface=local dst-port=80 protocol=tcp
the interface is the interface on witch the hotspot runs.
I know there is a better way to do this, but this nat rule has worked wonders for me, and i have not had any trouble what so ever with the web-proxy.

Who is online

Users browsing this forum: ashwinvpatil, Google [Bot], IPANetEngineer and 78 guests