Community discussions

 
ukzerosniper
Member Candidate
Member Candidate
Topic Author
Posts: 110
Joined: Tue Jul 23, 2013 9:20 pm

Correct Queue Setup

Thu Dec 27, 2018 11:35 am

Hi Guys,

I have been working on a VOIP QOS setup for my routers.

I have got the packets for the VOIP connections marked and they hit the queues correctly. My main question is have I set the queues up correctly to ensure priority for the VOIP packets?

I have based these Queues on a 10Mbps internet connection. I have brought the Queues down to 9M as a measure to ensure we are not saturating the internet connection and having packet loss outside our network.

I am marking packets based on the IPs of our VOIP provider and DSCP 46.

If there is anything else I need to add to this setup, please could you point it out and help me optimize it.


/ip firewall address-list
add address=x.x.x.x/x list=VoiceHost
add address=x.x.x.x/x list=VoiceHost
add address=x.x.x.x/x list=VoiceHost
add address=x.x.x.x/x list=VoiceHost


/ip firewall mangle
add action=mark-connection chain=forward comment=\
    "DSCP (TOS) 46 - Mark connection VOIP" dscp=46 new-connection-mark=VOIP \
    passthrough=yes
add action=mark-connection chain=forward comment=\
    "Src. Address List - Mark connection VOIP" new-connection-mark=VOIP \
    passthrough=yes src-address-list=VoiceHost
add action=mark-connection chain=forward comment=\
    "Dst. Address List - Mark connection VOIP" dst-address-list=VoiceHost \
    new-connection-mark=VOIP passthrough=yes
add action=mark-packet chain=forward comment="Mark packets VOIP" \
    connection-mark=VOIP new-packet-mark=VOIP passthrough=yes
                

/queue simple
add max-limit=1M/1M name=VOIP packet-marks=VOIP priority=1/1 target=\
    192.168.10.0/24
add max-limit=1M/9M name="everything else" packet-marks=no-mark target=\
    192.168.10.0/24 total-queue=default

Who is online

Users browsing this forum: No registered users and 113 guests