Page 1 of 1

PWR-Line AP - problem with cominicate

Posted: Sat Dec 29, 2018 10:35 am
by WojtusW5
Hi, I have 2 PWR-Line devices for tests.
They have RouterOS 6.42.7 and default config.
I am doing a pairing instruction:
https://i.mt.lv/cdn/rb_files/1544441162 ... -AP-qg.pdf
On both devices the orange LEDs are constantly on but I don't have cominicate between device.
Please help becouse I don't have any idea to solve this problem.

Re: PWR-Line AP - problem with cominicate

Posted: Sat Dec 29, 2018 10:53 am
by Joni
Begin by trying to pair them on the same extension cord, side by side.

Re: PWR-Line AP - problem with cominicate

Posted: Sat Dec 29, 2018 11:07 am
by WojtusW5
That's what I do.
The orange and blue LEDs are permanently on.
The diode with the network icon (drawn green) flashes.

Re: PWR-Line AP - problem with cominicate

Posted: Sat Dec 29, 2018 11:30 am
by Joni
Typical Mikrotik, making a device with six leds and two buttons but not documenting more than one led in one state... reminds me of cAP Lite (RBcAPL-2nD-307)...

Re: PWR-Line AP - problem with cominicate

Posted: Sat Dec 29, 2018 12:35 pm
by mkx
They're not discoverable by winbox? Even if you connect computer directly to their ethernet port?

Re: PWR-Line AP - problem with cominicate

Posted: Sat Dec 29, 2018 12:57 pm
by WojtusW5
I see them separately when I connect the cable to it. But they do not see each other.

Device 1:
[admin@MikroTik] > export 
# dec/29/2018 11:52:21 by RouterOS 6.42.7
# software id = 1TNZ-061I
#
# model = PL7411-2nD
# serial number = 9E7509A09BF0
/interface bridge
add admin-mac=B8:69:F4:BA:DA:78 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no frequency=auto mode=ap-bridge rx-chains=0,1 ssid=MikroTik-BADA7B tx-chains=0,1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge comment=defconf interface=ether1
add bridge=bridge comment=defconf interface=wlan1
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=bridge
/system clock
set time-zone-name=Europe/Warsaw
/system routerboard settings
set silent-boot=no
[admin@MikroTik] > ip neighbor export verbose 
# dec/29/2018 11:52:39 by RouterOS 6.42.7
# software id = 1TNZ-061I
#
# model = PL7411-2nD
# serial number = 9E7509A09BF0
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
[admin@MikroTik] > ip neighbor print          
 # INTERFACE ADDRESS                                                                                                              MAC-ADDRESS       IDENTITY   VERSION    BOARD                                                                            
[admin@MikroTik] > 
Device 2:
[admin@MikroTik] > export                     
# dec/29/2018 11:55:21 by RouterOS 6.42.7
# software id = 6NNU-0U9V
#
# model = PL7411-2nD
# serial number = 9E7509EF34C7
/interface bridge
add admin-mac=B8:69:F4:BA:DA:84 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no frequency=auto mode=ap-bridge rx-chains=0,1 ssid=MikroTik-BADA87 tx-chains=0,1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge comment=defconf interface=ether1
add bridge=bridge comment=defconf interface=wlan1
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=bridge
/system clock
set time-zone-name=Europe/Warsaw
/system routerboard settings
set silent-boot=no
[admin@MikroTik] > ip neighbor export verbose 
# dec/29/2018 11:55:24 by RouterOS 6.42.7
# software id = 6NNU-0U9V
#
# model = PL7411-2nD
# serial number = 9E7509EF34C7
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
[admin@MikroTik] > ip neighbor print          
 # INTERFACE ADDRESS                                                                                                              MAC-ADDRESS       IDENTITY   VERSION    BOARD                                                                            
 0 ether1    172.20.150.17                                                                                                                                               
[admin@MikroTik] > 
172.20.150.17 is my computer IP

Re: PWR-Line AP - problem with cominicate

Posted: Sat Dec 29, 2018 1:11 pm
by WojtusW5
After upgrade to 6.43.8, it started working.
The interface pwr-line1 also appeared.
Surprisingly, the factory equipment was 6.42.7 ...
Nevertheless, thank you everyone.

Re: PWR-Line AP - problem with cominicate

Posted: Sat Dec 29, 2018 1:13 pm
by mkx
I'm not familiar with Mikrotik's PWR-Line device, but for sure there's another physical interface (probably /interface print would show it) which should become member of bridge. Only then your both PWR-Line devices would connect to single network.

Another issue might be that both devices actually didn't pair. See if it's possible to manually set the pairing key instead of (WPS-like) auto key generation ... that would come handy in case you wanted to add another PWR-Line device to the running PWR-Line network.

[edit] Good to know that ROS upgrade fixed it.

Re: PWR-Line AP - problem with cominicate

Posted: Mon Dec 31, 2018 12:18 pm
by ronniee
I test a pair of these APs, but can't find a description.
What is the maximum distance to work etc.
After upgrade to 43.8 a pwr-line1 interface appeared, there is a Config button, with Newtork Key/Network Password/PCL Mode.

Re: PWR-Line AP - problem with cominicate

Posted: Mon Dec 31, 2018 3:11 pm
by Joni
I test a pair of these APs, but can't find a description.
What is the maximum distance to work etc.
https://mikrotik.com/product/pwr_line_ap says the PLC chipset is https://www.qualcomm.com/products/ar7420 which says
Ethernet Standards: Home Plug 1.0, Home Plug AV, IEEE 802.3, IEEE 1900
Ethernet Network: 10/100
Powerline Frequency Bands: 67.5 MHz
Powerline Configuration: SISO
which translates to https://en.m.wikipedia.org/wiki/HomePlug
HomePlug AV offers a peak data rate of 200 Mbit/s at the physical layer, and about 80 Mbit/s at the MAC layer.
The general consensus for distance (combined between all PLC devices in one group) seems to be < 200 meters, in perfect conditions.
Unfortunately Mikrotik didn't go the G.hn way: https://en.m.wikipedia.org/wiki/G.hn