Community discussions

 
nyitguy
just joined
Topic Author
Posts: 1
Joined: Mon Jan 15, 2018 9:46 pm

Design help - PLEASE

Sat Dec 29, 2018 10:47 pm

I am using the CHR product with RouterOS 6.43.8 along with Hyper-V to set up a test scenario. In Hyper-V I've set up 3 virtual switches: External (connects to my PC and ether1 on the CHR), Private1 (connected to a virtual CentOS7 PC with VLAN connections configured on eth0. Also connected to ether2), and Private2 (connected to another generic CentOS7 system and ether3). I'm trying to configure the following without success:

ether1 - Internet. This is set to DHCP and gets an IP from my local network. I am able to ping Internet address from the console.
ether2 - Tagged VLAN 100 and 101 traffic. This simulates my wireless network which maps users to a VLAN based on their logins.
ether3 - Untagged VLAN 101 traffic.

Here is my current configuration. I've attempted to set up a single bridge with vlan-filtering. I am unable to get IP addresses from the DHCP servers on my virtual PCs.
# Set up WAN interface (ether1)
/ip dhcp-client add interface=ether1 comment=Internet
/ip firewall nat add chain=srcnat src-address=192.168.1.0/24 out-interface=ether1

#Single Bridge Configuration with VLAN Filtering
/interface bridge add name=bridge vlan-filtering=no

#Set up VLAN100
/interface vlan add name=vlan100-gw interface=bridge vlan-id=100
/ip address add address=192.168.100.1/24 interface=vlan100-gw
/ip pool add name=pool-vlan100 ranges=192.168.100.10-192.168.100.50
/ip dhcp-server add name=dhcp-vlan100 interface=vlan100-gw authoritative=yes lease-time=8:00:00 address-pool=pool-vlan100 disabled=no
/ip dhcp-server network add address=192.168.100.0/24 gateway=192.168.100.1 domain=admin dns-server=208.67.222.222,208.67.220.220

#Set up VLAN101
/interface vlan add name=vlan101-gw interface=bridge vlan-id=101
/ip address add address=192.168.101.1/24 interface=vlan101-gw
/ip pool add name=pool-vlan101 ranges=192.168.101.10-192.168.101.50
/ip dhcp-server add name=dhcp-vlan101 interface=vlan101-gw authoritative=yes lease-time=8:00:00 address-pool=pool-vlan101 disabled=no
/ip dhcp-server network add address=192.168.101.0/24 gateway=192.168.101.1 domain=admin dns-server=208.67.222.222,208.67.220.220

#Configure bridge ports
/interface bridge vlan add bridge=bridge vlan-ids=100 tagged=ether2,vlan100-gw
/interface bridge vlan add bridge=bridge vlan-ids=101 tagged=ether2,vlan101-gw untagged=ether3
/interface bridge set [find name=bridge] vlan-filtering=yes
Thank you!!!

Who is online

Users browsing this forum: No registered users and 119 guests