Community discussions

 
cdoyle4785
just joined
Topic Author
Posts: 6
Joined: Mon Apr 17, 2017 6:58 am

QoS Simple Queue Limitation? Traffic stops accounting for on the last most child queue to 'wan' parent queue

Wed Jan 02, 2019 5:03 am

Hello,


Having a weird issue... particularly, i think it's probably got something to do with the underlying code, in addition to the subnet hack in place to cover multiple LAN subnets in one WAN queue's ...


Here is the Queue config snippet:


[comtruise@Hex] > /queue simple export hide-sensitive
# jan/01/2019 21:50:12 by RouterOS 6.43.8
# software id = x
#
# model = RouterBOARD 750G r3
# serial number = x
/queue simple
add comment=defautl_LAN dst=192.168.0.0/16 name=LAN queue=ethernet-default/ethernet-default target=192.168.0.0/16 total-queue=ethernet-default
add comment=default_WAN_parent limit-at=2M/25M max-limit=2355k/30M name=WAN queue=pcq-upload-default/pcq-download-default target=192.168.0.0/16 total-queue=default
add limit-at=64k/2880k max-limit=384k/15M name=tv_network parent=WAN queue=pcq-upload-default/pcq-download-default target=192.168.1.15/32
add burst-time=1s/1s comment=security limit-at=64k/64k max-limit=2355k/30M name=sec parent=WAN priority=7/7 queue=pcq-upload-default/pcq-download-default target=192.168.1.252/32 total-queue=\
default
add burst-time=3s/3s limit-at=1792k/22528k max-limit=2355k/30M name=data parent=WAN priority=5/5 queue=pcq-upload-default/pcq-download-default target=192.168.1.0/24 total-queue=default
[comtruise@Hex] >




So, what happens:
If we have all the 'queue' open in winbox, and watching each queue we have selected the 'traffic' window, you can see the lowest most queue will stop tracking the traffic conditions on the graph after some few seconds... disable and enable parent queue or a queue above sometimes fixes it, where tracking starts again... but shortly will stop once it reaches 4 child queue's of the parent queue WAN.


In other words:
If there are 4 child queue's under the Parent queue WAN, then the last most queue will stop tracking traffic....
Had to drop it down to 3 queue's.



So, Queue in numbered In order:
0 - LAN
1 - tv_network
2 - security
3 - data
4 - WAN
*where queue's as numbered 1-3 are children of the parent queue 'WAN'.


Please, is this a bug report.. is this something i'm breaking?... I would like to find a better way to account for traffic...
Possibly have a queue pipeline for the overall WAN connection, and then priorityse based on dst-port or other classifiers...

Simple queue is not yet simple enough!!! :P (sarcasm!) :)
(PS, don't judge my queue speed-limits...Okay judge away... Local ISP Comcrapst's lowest internet package is the only 'reliable' package they can deliver to our household without packetloss or service degredation, Lol :/ )


Keep up the great work Mikrotik!!! You are sweeping the nation... Can we open source the software yet?


Thank in advance for any input/guidance/opinions/tips/pointers on the queue methodology here!!
















ps, here are the queue modifications if any


/queue type
set 0 kind=pfifo name=default pfifo-limit=50
set 1 kind=pfifo name=ethernet-default pfifo-limit=50
set 2 kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
set 3 kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10
set 4 kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
set 5 kind=pcq name=pcq-upload-default pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50KiB pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=\
128 pcq-total-limit=2000KiB
set 6 kind=pcq name=pcq-download-default pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50KiB pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=\
128 pcq-total-limit=2000KiB
set 7 kind=none name=only-hardware-queue
set 8 kind=mq-pfifo mq-pfifo-limit=50 name=multi-queue-ethernet-default
set 9 kind=pfifo name=default-small pfifo-limit=10

Who is online

Users browsing this forum: No registered users and 23 guests