Community discussions

 
networknoob88
newbie
Topic Author
Posts: 43
Joined: Sun Jul 15, 2018 6:00 pm

For a CCR without switch chip, any way to do packet redirection based on MAC protocol?

Sat Jan 12, 2019 5:14 am

I'm trying to bypass an ISP-issued gateway router with my CCR1009 7G (no switch chip), which involves redirecting EAP packets to the ISP hardware (for authentication).

On a Mikrotik router with a switch chip, the following switch rules would achieve this:

/interface ethernet switch rule add switch=switch1 ports=ether1 mac-protocol=0x888E new-dst-ports=ether2
/interface ethernet switch rule add switch=switch1 ports=ether2 mac-protocol=0x888E new-dst-ports=ether1

But since my CCR does not have a switch chip, is there any workaround that can be used to achieve this? Can "bridge filtering" be used for this purpose?
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1713
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: For a CCR without switch chip, any way to do packet redirection based on MAC protocol?

Sat Jan 12, 2019 9:49 am

try using a bridge and bridge rules, maybe that can help
 
networknoob88
newbie
Topic Author
Posts: 43
Joined: Sun Jul 15, 2018 6:00 pm

Re: For a CCR without switch chip, any way to do packet redirection based on MAC protocol?

Sat Jan 12, 2019 9:07 pm

try using a bridge and bridge rules, maybe that can help

I tried. I created a bridge filter, and filtered by mac-protocol 0x888e. I can see the EAP packets coming from the ISP RG, but the problem is I can't do anything with it. The filter only allows me to accept drop etc. I need to redirect those packets. I also tried the bridge NAT, which I believe is processed before the bridge filter, but it can't see any packets with that mac protocol.
 
networknoob88
newbie
Topic Author
Posts: 43
Joined: Sun Jul 15, 2018 6:00 pm

Re: For a CCR without switch chip, any way to do packet redirection based on MAC protocol?

Sun Jan 13, 2019 5:48 pm

I'm considering buying a Mikrotik switch to do this.
Quick question: can SWOS's web GUI achieve this feature? Or does it have to be a full blown RouterOS based switch?
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: For a CCR without switch chip, any way to do packet redirection based on MAC protocol?

Sat Jan 19, 2019 12:42 am

I'm trying to bypass an ISP-issued gateway router with my CCR1009 7G (no switch chip), which involves redirecting EAP packets to the ISP hardware (for authentication). But since my CCR does not have a switch chip, is there any workaround that can be used to achieve this? Can "bridge filtering" be used for this purpose?

Please see my post here. The riddle has been solved.

Who is online

Users browsing this forum: No registered users and 47 guests