Community discussions

 
lcfnet
just joined
Topic Author
Posts: 1
Joined: Fri Jan 11, 2019 9:57 am

5 WAN and 2 LAN PCC Load Balance

Wed Jan 16, 2019 1:58 am

I am using RB1100Dx4 RouterOS 6.43.8 with WAN and 2 LAN.

WAN1 : ~10 Mbps
WAN2 - WAN5 : ~60 - 90 Mbps
They are 4G SIM card Routers.

After PCC setting, the speed is very slow.... I check many times but still can't find any mistakes.

Here is my setting:
/ip address
add address=192.168.88.1/24 interface=bridge1 network=192.168.88.0
add address=192.168.55.1/24 interface=bridge2 network=192.168.55.0

/interface list member


add interface=ether1_WAN1 list=WAN
add interface=ether2_WAN2 list=WAN
add interface=ether3_WAN3 list=WAN
add interface=ether4_WAN4 list=WAN
add interface=ether5_WAN5 list=WAN
add interface=ether6 list=LAN
add interface=ether7 list=LAN
add interface=ether8 list=LAN
add interface=ether9 list=LAN
add interface=ether10 list=LAN
add interface=ether12 list=LAN
add interface=ether11 list=LAN
add interface=ether13 list=LAN
add interface=bridge1 list=LAN
add interface=bridge2 list=LAN

/ip address
add address=192.168.88.1/24 interface=bridge1 network=192.168.88.0
add address=192.168.55.1/24 interface=bridge2 network=192.168.55.0

/ip firewall mangle
add action=accept chain=prerouting dst-address=192.168.0.0/24 in-interface-list=LAN
add action=accept chain=prerouting dst-address=192.168.12.0/24 in-interface-list=LAN
add action=accept chain=prerouting dst-address=192.168.34.0/24 in-interface-list=LAN
add action=accept chain=prerouting dst-address=192.168.56.0/24 in-interface-list=LAN
add action=accept chain=prerouting dst-address=192.168.78.0/24 in-interface-list=LAN
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1_WAN1 new-connection-mark=WAN_1_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2_WAN2 new-connection-mark=WAN_2_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether3_WAN3 new-connection-mark=WAN_3_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether4_WAN4 new-connection-mark=WAN_4_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether5_WAN5 new-connection-mark=WAN_5_conn passthrough=yes
add action=mark-connection chain=prerouting comment=Classifier connection-mark=no-mark dst-address-type=!local in-interface-list=LAN new-connection-mark=WAN_1_conn passthrough=yes per-connection-classifier=both-addresses:5/0
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local in-interface-list=LAN new-connection-mark=WAN_2_conn passthrough=yes per-connection-classifier=both-addresses:5/1
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface-list=LAN new-connection-mark=WAN_3_conn passthrough=yes per-connection-classifier=both-addresses:5/2
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface-list=LAN new-connection-mark=WAN_4_conn passthrough=yes per-connection-classifier=both-addresses:5/3
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface-list=LAN new-connection-mark=WAN_5_conn passthrough=yes per-connection-classifier=both-addresses:5/4
add action=mark-routing chain=prerouting connection-mark=WAN_1_conn in-interface-list=LAN new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN_2_conn in-interface-list=LAN new-routing-mark=to_WAN2 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN_3_conn in-interface-list=LAN new-routing-mark=to_WAN3 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN_4_conn in-interface-list=LAN new-routing-mark=to_WAN4 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN_5_conn in-interface-list=LAN new-routing-mark=to_WAN5 passthrough=yes
add action=mark-routing chain=output connection-mark=WAN_1_conn new-routing-mark=to_WAN1 passthrough=no
add action=mark-routing chain=output connection-mark=WAN_2_conn new-routing-mark=to_WAN2 passthrough=no
add action=mark-routing chain=output connection-mark=WAN_3_conn new-routing-mark=to_WAN3 passthrough=no
add action=mark-routing chain=output connection-mark=WAN_4_conn new-routing-mark=to_WAN4 passthrough=no
add action=mark-routing chain=output connection-mark=WAN_5_conn new-routing-mark=to_WAN5 passthrough=no

/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface-list=WAN

/ip route
add check-gateway=ping distance=1 gateway=8.8.4.4 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=8.8.4.4 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=8.8.4.4 routing-mark=to_WAN3
add check-gateway=ping distance=1 gateway=8.8.4.4 routing-mark=to_WAN4
add check-gateway=ping distance=1 gateway=8.8.4.4 routing-mark=to_WAN5
add distance=1 dst-address=8.8.4.4/32 gateway=10.93.192.17 scope=10
add distance=2 dst-address=8.8.4.4/32 gateway=192.168.12.1 scope=10
add distance=3 dst-address=8.8.4.4/32 gateway=192.168.34.1 scope=10
add distance=4 dst-address=8.8.4.4/32 gateway=192.168.56.1 scope=10
add distance=5 dst-address=8.8.4.4/32 gateway=192.168.78.1 scope=10


I tried to disable all mangle rules. But the speed test shows only 2 to 5 Mbps.... I have no idea whats wrong with it...
 
Almohalla
just joined
Posts: 10
Joined: Fri Jan 15, 2016 7:31 pm

Re: 5 WAN and 2 LAN PCC Load Balance

Tue Apr 30, 2019 3:37 pm

You are using Load Balancing for equal WANs while your WANs not all equal so you should use unequal load balancing PCC Method.
If you found a solution please share here.
 
McSee
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Tue Feb 26, 2019 12:49 pm

Re: 5 WAN and 2 LAN PCC Load Balance

Tue Apr 30, 2019 4:12 pm

Look at these 5 routes below on your mikrotik after they have been added. How many of them are active ?
.
add distance=1 dst-address=8.8.4.4/32 gateway=10.93.192.17 scope=10
add distance=2 dst-address=8.8.4.4/32 gateway=192.168.12.1 scope=10
add distance=3 dst-address=8.8.4.4/32 gateway=192.168.34.1 scope=10
add distance=4 dst-address=8.8.4.4/32 gateway=192.168.56.1 scope=10
add distance=5 dst-address=8.8.4.4/32 gateway=192.168.78.1 scope=10
 
sindy
Forum Guru
Forum Guru
Posts: 4011
Joined: Mon Dec 04, 2017 9:19 pm

Re: 5 WAN and 2 LAN PCC Load Balance

Tue Apr 30, 2019 4:26 pm

Do you have an enabled rule with action=fasttrack-connection in your /ip firewall fiter?

If yes, disable it. Most packets of fasttracked connections skip all firewall handling, which means that the initial packets choose the WAN according to your load balancing rules, but most of the subsequent ones don't (no mangle rules traversed => no routing marks assigned) so they get lost and need to be retransmitted. As every Nth packet is not handled in fasttrack mode, the connections don't break but appear slow.

Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.

Who is online

Users browsing this forum: MSN [Bot] and 68 guests