Community discussions

MikroTik App
 
Mimiko
just joined
Topic Author
Posts: 18
Joined: Sat May 20, 2017 3:28 pm

RB951-2n VLAN problem

Thu Jan 24, 2019 8:09 pm

Hello.
I want to setup VLAN using switch chip on RB951-2n.

I do this:
/interface bridge
add name=LAN
add name=WAN protocol-mode=none
/interface vlan
add interface=LAN loop-protect=on name=vlan1 vlan-id=9
add interface=LAN loop-protect=on name=vlan10 vlan-id=10
add interface=LAN loop-protect=on name=default vlan-id=1
add interface=LAN loop-protect=on name=vlan11 vlan-id=11
/interface ethernet switch port
set 0 default-vlan-id=10 vlan-header=always-strip vlan-mode=secure
set 1 default-vlan-id=10 vlan-header=always-strip vlan-mode=secure
set 2 default-vlan-id=10 vlan-header=always-strip vlan-mode=secure
set 3 default-vlan-id=10 vlan-header=always-strip vlan-mode=secure
set 4 default-vlan-id=10 vlan-mode=secure
/interface bridge port
add bridge=WAN interface=ether1
add bridge=LAN interface=ether2
add bridge=LAN interface=ether3
add bridge=LAN interface=ether4
add bridge=LAN interface=ether5
/interface ethernet switch vlan
add ports=switch1-cpu switch=switch1
add ports=switch1-cpu switch=switch1 vlan-id=1
add ports=switch1-cpu switch=switch1 vlan-id=9
add ports=switch1-cpu,ether2,ether3,ether4,ether5 switch=switch1 vlan-id=10
add ports=switch1-cpu switch=switch1 vlan-id=11
/ip address
add address=10.10.0.78/16 disabled=yes interface=WAN network=10.10.0.0
add address=10.29.9.254/24 interface=vlan10 network=10.29.9.0

A computer connected to one of ports ether 2-ether5 and having ip 10.29.9.100/24 cannot ping the router or access internet (I skipped internet routing).

If I set: /ip address add address=10.29.9.254/24 interface=LAN network=10.29.9.0

Then computer can ping router and have internet. But then all ports are implicitly in vlan10. If I would like to set ether5 to vlan9 then it will not work.

Same configuration on hAP ac lite works ok. Also ok is for CCR, RB2011 3011. And even on Cap ac. What is the problem with RB951-2n?
Firwmare is latest version.

Thank you.

Who is online

Users browsing this forum: Google [Bot], heinsk and 76 guests