Community discussions

MUM Europe 2020
 
cushenst
just joined
Topic Author
Posts: 10
Joined: Fri Dec 22, 2017 7:51 pm

Slow speeds on fibre with pppoe

Fri Jan 25, 2019 7:10 pm

Hi,
A few of us are trying to figure out why we aren’t getting full speed through a fibre connection. The fibre link has been tested to be capable of 1gbps.

We have a pppoe Server running on a vlan on a ccr1016-12S-1S+ which then connects through the fibre on a vlan to a rb1100ahx2. This runs a pppoe client on the vlan.

Then highest speed we are able to achieve is about 500-520mbps when running a btest from client to server. We have been told the line mtu is 1500. The negotiated mtu of the pppoe interface is 1480.

Only a basic configuration is on both routers. Any advice would be great. If you require any more information please let me know.

Stephen
 
User avatar
jprietove
Trainer
Trainer
Posts: 96
Joined: Fri Jun 03, 2016 3:00 pm
Location: Cádiz, Spain
Contact:

Re: Slow speeds on fibre with pppoe

Fri Jan 25, 2019 7:24 pm

Test mtu with ping and no fragment option. VLAN has additional bytes in header so instead of 1480 maybe it's 4 bytes less.


Enviado desde mi Redmi 3 mediante Tapatalk

 
cushenst
just joined
Topic Author
Posts: 10
Joined: Fri Dec 22, 2017 7:51 pm

Re: Slow speeds on fibre with pppoe

Fri Jan 25, 2019 7:56 pm

Thanks for your reply. I am able to ping both ways with a max packet size of 1480 without it complaining of fragmentation. (1480 all pings fine. 1481 pings fail due to fragmentation).
 
Paternot
Long time Member
Long time Member
Posts: 607
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: Slow speeds on fibre with pppoe

Fri Jan 25, 2019 9:17 pm

Then highest speed we are able to achieve is about 500-520mbps when running a btest from client to server. We have been told the line mtu is 1500. The negotiated mtu of the pppoe interface is 1480.
Are You running the btest client/server on the routers being tested? One shouldn't do it, as the btest is quite CPU hungry, and will affect your speeds.

Try running something between two computers, behind the routers.
 
cushenst
just joined
Topic Author
Posts: 10
Joined: Fri Dec 22, 2017 7:51 pm

Re: Slow speeds on fibre with pppoe  [SOLVED]

Tue Feb 05, 2019 8:50 pm

Hi, Thanks. We were able to lower the mtu to 1436 and that seems to have solved the problems. We are now maxing out our transit providers.

Who is online

Users browsing this forum: No registered users and 86 guests