Community discussions

MikroTik App
 
halacs
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Thu Jul 06, 2017 5:45 pm

Performance of Mikrotik 951G-2HnD

Sat Feb 02, 2019 9:50 pm

Hi,

I have a Mikrotik 951G-2HnD router. I suspect it is the bottleneck of my network why I cannot reach Internet with 500Mbps/20Mbps what my ISP should provide. I would like to know what can cause this: configuration of my device or hardware failure.

I can measure maximum 100-120Mbps download speed even if I am connected to my Mikrotik 951G-2HnD device directly with CAT5e cable.
To make sure, not my ISP is the guilty, I connected a PC to the WAN port and did measurements between that WAN side PC and another one in my LAN but I could measure the same speeds so it seems my router is the bottleneck somehow.

What my router do?
- NAT (DHCP client on WAN)
- IPv6 tunnel
- DHCP server
- L2TP VPN and OpenVPN site2site VPN (less then 5 clients and minimal traffic between my flats). L2TP VPN is configured as Layer2 connection because of DLNA server in my primary flat.
- Two WiFi network (guest SSID with only internet and "normal" for the family)
- Two tagged VLAN network (guest and "normal" as in case of wifi). Trunk VLAN cable towards my smart switch where all the PCs are connected.

I have checked the CPU usage when I'm measuring but it's under 90% always.

I highly appreciate your help and advice.

Thanks & br,
Halacs
 
mkx
Forum Guru
Forum Guru
Posts: 4317
Joined: Thu Mar 03, 2016 10:23 pm

Re: Performance of Mikrotik 951G-2HnD

Sat Feb 02, 2019 10:04 pm

Do you have fasttrack rule in FW filter rule list?

Anyhow, 500Mbps with some decent FW is on the edge of what this device can deliver. And with fairly optimized FW rule list ...
BR,
Metod
 
Pea
Member Candidate
Member Candidate
Posts: 206
Joined: Fri Jul 17, 2015 11:07 pm
Location: Czech

Re: Performance of Mikrotik 951G-2HnD

Sat Feb 02, 2019 10:07 pm

Maybe Fasttrack rule missing in your firewall?
https://wiki.mikrotik.com/wiki/Manual:IP/Fasttrack
/ip firewall filter add chain=forward action=fasttrack-connection connection-state=established,related
/ip firewall filter add chain=forward action=accept connection-state=established,related
 
halacs
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Thu Jul 06, 2017 5:45 pm

Re: Performance of Mikrotik 951G-2HnD

Sat Feb 02, 2019 10:27 pm

I have just added the above two fasttrack firewall rules and my connection immediately because 2 times faster then before so this was definitely the problem. Big thanks!
Just to make sure I understand correctly: they should be at the top of my firewall rules, right?

Mkx, you mentioned 500Mbps is the edge of what this device can deliver. Can you suggest a similar device what is good up to 1Gbps/1Gbps connection? 2Gbps/2Gbps is the max what my ISP offers but half of it is more then enough for me even if I take into consideration my multi-homed life too. If my device would have a higher capacity at an affordable price, even better of course. (I don't know where I can find this kind of info in the catalogs)
 
mkx
Forum Guru
Forum Guru
Posts: 4317
Joined: Thu Mar 03, 2016 10:23 pm

Re: Performance of Mikrotik 951G-2HnD

Sat Feb 02, 2019 10:31 pm

I'd say that RBD52G (hAP ac2) would be able to get near Gbps ... not single connection though.
BR,
Metod
 
halacs
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Thu Jul 06, 2017 5:45 pm

Re: Performance of Mikrotik 951G-2HnD

Sat Feb 02, 2019 10:56 pm

Great, thanks, I will check that one! Do you have any hint where I can find these performance related parameters? Where do you know these from?
 
Pea
Member Candidate
Member Candidate
Posts: 206
Joined: Fri Jul 17, 2015 11:07 pm
Location: Czech

Re: Performance of Mikrotik 951G-2HnD

Sat Feb 02, 2019 11:43 pm

 
halacs
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Thu Jul 06, 2017 5:45 pm

Re: Performance of Mikrotik 951G-2HnD

Sun Feb 03, 2019 9:04 am

In case of RB951G-2HnD device, "Routing, 25 ip filter rules, 689.8 Mbps" is shown under the test results for 1518 byte packet size.

Does this mean, that if I have just 25 IP filter rules (under IP / Firewall / Filter Rules), then I should be able to reach this throughput without fast track rules? Well, in my case, with no fast track rules, I could reach a much worst speed, however, I have actually exactly 25 (with the 3 disabled ones).
 
Pea
Member Candidate
Member Candidate
Posts: 206
Joined: Fri Jul 17, 2015 11:07 pm
Location: Czech

Re: Performance of Mikrotik 951G-2HnD

Sun Feb 03, 2019 9:56 am

*)
All tests are done with Xena Networks specialized test equipment (XenaBay),and done according to RFC2544 (Xena2544)
Max throughput is determined with 30+ second attempts with 0,1% packet loss tolerance in 64, 512, 1518 byte packet sizes
Test results show device maximum performance, and are reached using mentioned hardware and software configuration, different configurations most likely will result in lower results


Translation: These results are reached only within ideal and specific conditions, this is the maximum which is unreachable in other setups.
You should read this the same way as car fuel consumption, electric car drive distance, display contrast, WiFi speed, ... :)

Just use these numbers to compare the huge performance difference of both devices an upgrade if you need better router.
 
halacs
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Thu Jul 06, 2017 5:45 pm

Re: Performance of Mikrotik 951G-2HnD

Sun Feb 03, 2019 10:15 am

Thanks! This helped me a lot!
 
mkx
Forum Guru
Forum Guru
Posts: 4317
Joined: Thu Mar 03, 2016 10:23 pm

Re: Performance of Mikrotik 951G-2HnD

Sun Feb 03, 2019 10:36 am

My rule of thumb is to look at number for most loaded firewall (i.e. the lowest line in the table) and packet size of 512 bytes. My feeling is that this number gives best approximation for max performance for typical SOHO use.

Surely if one gets overboard with number of rules (we've seen some examples on this forum), then performance might be even lower.
When squeezing router for every last bit of performance, the order of filter rules does matter and can bring a few percent of performance.
BR,
Metod

Who is online

Users browsing this forum: altermeinhausbrennt, Infatuas, jebz, robertkjonesjr, sfrode and 52 guests