Community discussions

 
Sergius
just joined
Topic Author
Posts: 2
Joined: Fri Feb 08, 2019 3:44 pm

VLAN tunnling IEE 802.1ad

Fri Feb 08, 2019 4:00 pm

I'm trying realise what is happening when swithes use VLAN tunnling IEE 802.1ad(Service VLAN)
I'v got the example from here: https://wiki.mikrotik.com/wiki/Manual:B ... ling_setup
Switches have the same configuration:
/interface bridge
add name=bridge1 vlan-filtering=yes ether-type=0x88a8
/interface bridge port
add interface=ether1 bridge=bridge1 pvid=200
add interface=ether2 bridge=bridge1 pvid=300
add interface=ether3 bridge=bridge1
/interface bridge vlan
add bridge=bridge1 tagged=ether3 untagged=ether1 vlan-ids=200
add bridge=bridge1 tagged=ether3 untagged=ether2 vlan-ids=300
I've simplified topology a litle bit.
Let's look at the picture. Note1 is sending ICMP requests to Note2.
At the same time PacketSniffer is running on the SW1.
Image
All is working well but the resaults:

Both switch bridges have the same Ether-type=0x88a8 and as Wiki says, packets at the
access ports(ether2) should get ehter-type 0x88a8 and VLANID=300, but
as you see that transmitted(tx) packets from ether3 port have ehter-type=8100.
Fether more! The same packets reseived (rx)at the SW2 ether3 port already have ehter-type=0x88a8.
What's going on?
You do not have the required permissions to view the files attached to this post.
 
Sergius
just joined
Topic Author
Posts: 2
Joined: Fri Feb 08, 2019 3:44 pm

Re: VLAN tunnling IEE 802.1ad

Sat Feb 09, 2019 4:50 pm

I tried to understand, and here are my suggestions.
When HW Offloading is off, packet analysis is possible because traffic passes through the CPU
When a packet leaves the ether1 port, sniffing is performed before the packet has changed its ether-type
picture Bridge Hardware Offload turned off bridge ether-type 0x88a8.jpg
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: CZFan, kivimart, sethchouinard, Sob and 26 guests