Page 1 of 1

Force SmartDNS DNS for PS4 only

Posted: Sun Feb 17, 2019 3:20 pm
by Thor187
How can I force smartDNS’s DNS for only the IP address of my PS4 (static IP)

I do not want to use smartdns for all traffic just the PS4 for netflix.

I initially had this: but this routes all dns traffic.

Code: Select all

add chain=dstnat action=dst-nat to-addresses=154.127.57.224 to-ports=53 protocol=tcp dst-port=53
add chain=dstnat action=dst-nat to-addresses=154.127.57.224 to-ports=53 protocol=udp dst-port=53
But I do not know where to put 192.168.88.4 in the list.


Code: Select all

192.168.88.4 = PS4 static IP
154.127.57.224 = SmartDNS

Re: Force SmartDNS DNS for PS4 only

Posted: Sun Feb 17, 2019 3:38 pm
by sebastia
add to the above rules:
src-address=<ip ps4>

but easiest would be if you configure the dns server on ps4 itself.

Re: Force SmartDNS DNS for PS4 only

Posted: Sun Feb 17, 2019 8:40 pm
by Thor187
I did that.

But it still goes to Google's DNS (does not matter what the DNS settings are on the mikrotik.)

IP below is for the PS4 (different mikrotik)
2019-02-17_15-01-53.png

Re: Force SmartDNS DNS for PS4 only

Posted: Sun Feb 17, 2019 8:42 pm
by Thor187
add to the above rules:
src-address=<ip ps4>

but easiest would be if you configure the dns server on ps4 itself.
Does not work as that is done already, netflix is hardcoded to use 8.8.8.8

Re: Force SmartDNS DNS for PS4 only

Posted: Sun Feb 17, 2019 9:20 pm
by sebastia
The bridge is your lan bridge? Then that torch doesn't prove anything, as it's show the traffic client sees. Natting happens after the packets are received on the bridge.
If you want to verify that: try logging in forward table.

Re: Force SmartDNS DNS for PS4 only

Posted: Sun Feb 17, 2019 9:54 pm
by Thor187
This proves what the torch sees. Despite the nat entry, Netflix is still getting through to 8.8.8.8