Community discussions

MUM Europe 2020
 
ShadowManiac
just joined
Topic Author
Posts: 5
Joined: Wed Feb 20, 2019 4:36 am

Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Wed Feb 20, 2019 4:52 am

Dear MikroTik Community,

I have a problem with getting IP address from my ISP.

What could be the problem?

Very often, the Internet disappears for a short time, and then reappears. Previously, this did not happen :(

I'm new to router OS.Thank's guys. And sorry , my english bad :(
You do not have the required permissions to view the files attached to this post.
 
R1CH
Forum Veteran
Forum Veteran
Posts: 910
Joined: Sun Oct 01, 2006 11:44 pm

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Wed Feb 20, 2019 4:39 pm

Config? Maybe you're blocking important DHCP packets with the firewall.
 
zakynthoswifi
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Thu Jul 17, 2014 12:38 am
Location: Zakynthos
Contact:

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Wed Feb 20, 2019 5:50 pm

try to disable your firewall drop rules and keep an eye on it it must be fine...
Ilias Theodosis
Network & Security Engineer
Cisco CCNA,CCNP,CCIE
Network Solutions Ltd.
Zakynthos, Greece
 
anav
Forum Guru
Forum Guru
Posts: 3159
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Wed Feb 20, 2019 7:03 pm

Bad cable between ISP device and router?
FW rules (input chain rules are interfering).

Hard to say when one doesn't post their config!!!
/export hide-sensitive file=yourconfig
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
ShadowManiac
just joined
Topic Author
Posts: 5
Joined: Wed Feb 20, 2019 4:36 am

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Wed Feb 20, 2019 8:19 pm

Bad cable between ISP device and router?
FW rules (input chain rules are interfering).

Hard to say when one doesn't post their config!!!
/export hide-sensitive file=yourconfig
My config:
myconfig.rsc
You do not have the required permissions to view the files attached to this post.
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1796
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Wed Feb 20, 2019 9:02 pm

What is connected to ether1?
 
ShadowManiac
just joined
Topic Author
Posts: 5
Joined: Wed Feb 20, 2019 4:36 am

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Wed Feb 20, 2019 9:08 pm

What is connected to ether1?
My ISP gives the IP address - DHCP.

And i have second ISP with static IP. Static work fine.
 
anav
Forum Guru
Forum Guru
Posts: 3159
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Wed Feb 20, 2019 10:18 pm

First in reply you only have ether1 listed as part of your WAN (interface members list) but you are stating two ISPs???

Secondly your IP address is incorrect.
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=\
should be
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\

Thirdly if you have a second ISP then you need two sourcenat rules.

/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface=ether1 (for the dynamic ISP)
Plus an action=src-nat chain=srcnat rule for the fixed static ISP IP.

Also your DNS is in slight conflict and needs to be cleaned up.

/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1 dns=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,1.1.1.1
/ip dns static
add address=192.168.88.1 name=router.lan
Remove this static line its a quickset config that you dont need.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1796
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Wed Feb 20, 2019 10:59 pm

What is connected to ether1?
My ISP gives the IP address - DHCP.

And i have second ISP with static IP. Static work fine.
Both on same interface?
 
ShadowManiac
just joined
Topic Author
Posts: 5
Joined: Wed Feb 20, 2019 4:36 am

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Thu Feb 21, 2019 12:35 am

What is connected to ether1?
My ISP gives the IP address - DHCP.

And i have second ISP with static IP. Static work fine.
Both on same interface?
Yes, I connected another provider today. He has a static ip on WAN. And work perfectly.
But why is my main provider has DHCP on WAN and don't work correctly.

Log screenshot before connected second provider.I just reconfigured eth1 to static ip.And internet work perfectly.
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 648
Joined: Fri Nov 10, 2017 8:19 am

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Thu Feb 21, 2019 6:28 am

Personally, I would just run the sniffer which will give all answers:
/tool sniffer start interface=ether1-uplink port=68
and after some time (look at logs and wait until you lose and reacquire your IP few times)
/tool sniffer save file-name=dhcp.pcap
/tool sniffer stop
In the file, there will be DHCP packets captured. You can download it to your computer and use tools like Wireshark to read it.
Packets should go same way as described here: https://en.wikipedia.org/wiki/Dynamic_H ... #Operation
If they aren't in the same order, some packet is missing or some is repeated many times, it points to the issue. Skilled person should instantly know whats going on.
Usual reason is, that either client or server miss some packet and does not reply.
If you are unsure what to do with the recorded file, you may show it to someone more experienced or upload it here as attachment.
If you worry about not publishing your IP, well, you already did, because anyone with piece of brain can figure it out from your screenshot.
 
ShadowManiac
just joined
Topic Author
Posts: 5
Joined: Wed Feb 20, 2019 4:36 am

Re: Problem with DHCP Mikrotik RB962UIGS-5HACT2HNT

Thu Feb 21, 2019 10:32 pm

Personally, I would just run the sniffer which will give all answers:
/tool sniffer start interface=ether1-uplink port=68
and after some time (look at logs and wait until you lose and reacquire your IP few times)
/tool sniffer save file-name=dhcp.pcap
/tool sniffer stop
In the file, there will be DHCP packets captured. You can download it to your computer and use tools like Wireshark to read it.
Packets should go same way as described here: https://en.wikipedia.org/wiki/Dynamic_H ... #Operation
If they aren't in the same order, some packet is missing or some is repeated many times, it points to the issue. Skilled person should instantly know whats going on.
Usual reason is, that either client or server miss some packet and does not reply.
If you are unsure what to do with the recorded file, you may show it to someone more experienced or upload it here as attachment.
If you worry about not publishing your IP, well, you already did, because anyone with piece of brain can figure it out from your screenshot.
My snif
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 21 guests