Community discussions

User avatar
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 98
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

PPPoE client issue

Sun Feb 24, 2019 11:38 am

Having an issue with PPPoE Client (for ISP WAN connection) trying to replace a RB750 with a hEX unit.

Using a Draytek Vigor 120 v2 as PPPoA to PPPoE bridge
Working RB750 is on 6.42.6
hEX was on 6.43.8 but I'm planning to update to 6.43.12 before trying again

PPPoE client config:
/interface pppoe-client
add add-default-route=yes comment="PPP Dialer (via eth1)" dial-on-demand=yes disabled=no interface=ether1-gateway \
    keepalive-timeout=60 max-mru=1432 max-mtu=1432 name="Xilo DSL" password=xxxxx
Both old and new units, eth1 interfaces are configured with a IP address to enable management of the Vigor 120 (

I have tried temporarily disabling all filter drop rules as I had significantly tightened up my rules on the hEX (my RB750 had some of the default drop rules misconfigured for PPPoE WAN interface).

If dial on demand is enabled, status remains at waiting for packets. If I disable that, status goes to connected but immediately disconnects.

When switching back to the RB750 it takes several minutes to re-connect, this may relate to keep-alive. I have left the Vigor & ROS powered down for 10 minutes+ and tried again - still no luck.

Any suggestions? If I still have problems again this time, I will enable pppoe debug logging.

ISP and Draytek have suggested testing PPPoE client from a Windows PC.
RouterBOARD RB750 - Xilo ADSL2+ (Annex M)
RouterBOARD RB750GL - Xilo FTTC (VDSL)

Who is online

Users browsing this forum: Google [Bot] and 96 guests