Page 1 of 1

Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 7:18 pm
by knight782003
Imagei did not know what can i do for this
Mikrotik - Double-mac address
make my network unstable and i have many complains
any advise ?????? urgent

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 7:41 pm
by flynno
Hotspot Server
Addresses Per Mac ?

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 7:44 pm
by knight782003
not now i try it but make problem most of use kick out :(

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 7:47 pm
by flynno
Is Addresses Per Mac = 2

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 7:48 pm
by knight782003
no i was make address per mac= 1

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 7:51 pm
by flynno
Ok try set it to 2 and see if that helps you out

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 7:52 pm
by knight782003
i ll try now thanks any way for ur reply

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 9:39 pm
by knight782003
same issue i have 2 same mac and make the same problem i wanna know why that happen and if there is any way to prevent that :(

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 11:05 pm
by flynno
When did this start to happen?
How are your clients connecting to the hotspot? wireless / wired
Is your hotspot running on a bridge?
What is the IP pool of the hotspot?

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 11:22 pm
by flynno
You must be suffering from some kind of mac spoofing, if the clients are connecting to the hotspot from AP's, turn off default forward on the AP's
If you try connect to the hotspot using your device and see if you can ping other devices connected to the hotspot, if you can ping the devices you will need to add below rule;

/ip firewall nat add chain=pre-hotspot dst-address-type=!local hotspot=auth action=accept

Re: Mikrotik - Double-mac address

Posted: Sat Mar 16, 2019 11:33 pm
by knight782003
You must be suffering from some kind of mac spoofing, if the clients are connecting to the hotspot from AP's, turn off default forward on the AP's
If you try connect to the hotspot using your device and see if you can ping other devices connected to the hotspot, if you can ping the devices you will need to add below rule;

/ip firewall nat add chain=pre-hotspot dst-address-type=!local hotspot=auth action=accept
am let's say a big network cover more 500 users in daily basis all of them connected WIFI devices Nano M2 as access point all of them and Tplink E255 enterprise solution
i use hotpot router board ccr 1009
so appreciate ur reply but can you explain this rule
ip pool 10.0.0.1/22