Community discussions

 
jharry
just joined
Topic Author
Posts: 7
Joined: Tue Feb 26, 2019 11:47 pm

Very slow download speed when USB tethering to 4G phone

Wed Mar 20, 2019 12:20 pm

Hi All,

Currently I am using a OnePlus5T (Optus 4G) to USB tether with my Mikrotik RB750GR3, I can see the LTE1 interface and and a dhcp client is auto added. My problem lies with the download speed. Speedtest.net shows latency at 20ms and download at 0.05mbps while my upload speed is great at 15mbps. I don't believe it's a Firewall/Nat issue as sites load albeit very very slowly. Can anyone shed some light on this?

Many thanks.
 
NetWorker
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Sun Jan 31, 2010 6:55 pm

Re: Very slow download speed when USB tethering to 4G phone

Wed Mar 20, 2019 7:04 pm

My first guess would be the phone and or cell spectrum/backhaul. Did you check the phone with a PC at the same time you were getting these results? How much throughput did you get with that setup?

It's pretty common to see dismal download rates and high upload rates at times in highly congested cells. Especially when using AWG-1 or similar 4g bands where downlink and uplink are on different frequencies.

If that checks out, post your config for us to look at. But my money would NOT be on a firewall issue or anything like that as in that case traffic would either get through or it wouldn't.

Finally, a possible but unlikely culprit could be a bug in the usb driver. It has happened before, but again, it would either work or it wouldn't. Also look for high cpu usage (100%) and stray traffic (torch, packet sniffer, firewall connections, etc).
 
jharry
just joined
Topic Author
Posts: 7
Joined: Tue Feb 26, 2019 11:47 pm

Re: Very slow download speed when USB tethering to 4G phone

Thu Mar 21, 2019 3:49 am

Hi NetWorker,

I checked with a PC through USB Tethering and the speeds were excellent so I doubt that it has to do with cell congestion, I am also leaning towards a misconfigured USB driver in the Mikrotik router. I am posting a copy of the config below. When running through android 4G, I disable the cable connection dhcp client and change the masqurade to use LTE1
# mar/21/2019 12:20:57 by RouterOS 6.44.1
# software id = RLY1-NJ03
#
# model = RB750Gr3
# serial number = 
/interface bridge
add admin-mac=B8:69:XX:XX:XX:XX auto-mac=no comment=LAN1 name=bridge1
add admin-mac=B8:69:XX:XX:XX:XX auto-mac=no comment=LAN2 name=bridge2
/interface lte
set [ find ] mac-address=DA:92:XX:XX:XX:XX name=lte1
/interface ethernet
set [ find default-name=ether1 ] comment="ABB WAN"
set [ find default-name=ether2 ] comment=BR1
set [ find default-name=ether3 ] comment=BR1
set [ find default-name=ether4 ] comment=BR2
set [ find default-name=ether5 ] comment=BR2
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.0.2-192.168.0.254
add name=ovpn-pool ranges=192.168.8.2-192.168.8.99
add name=l2tp-pool ranges=192.168.9.2-192.168.9.99
add name=vpn ranges=192.168.89.2-192.168.89.255
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 name="DHCP LAN1"
/ppp profile
add dns-server=8.8.8.8,8.8.4.4 local-address=192.168.8.1 name=ovpn-profile remote-address=ovpn-pool use-encryption=yes
add dns-server=8.8.8.8 local-address=192.168.9.1 name=l2tp-profile remote-address=l2tp-pool wins-server=8.8.4.4
set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn
/interface bridge port
add bridge=bridge1 comment=BR1 interface=ether2
add bridge=bridge1 comment=BR1 interface=ether3
add bridge=bridge2 comment=BR2 interface=ether4
add bridge=bridge2 comment=BR2 interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface detect-internet
set detect-interface-list=all
/interface l2tp-server server
set default-profile=l2tp-profile enabled=yes use-ipsec=yes
/interface list member
add comment=LAN1 interface=bridge1 list=LAN
add comment="ABB WAN" disabled=yes interface=ether1 list=WAN
add comment=LAN2 disabled=yes interface=bridge2 list=LAN
add comment=WAN2 interface=lte1 list=WAN
/interface ovpn-server server
set auth=sha1 certificate=server-certificate cipher=aes128,aes256 default-profile=ovpn-profile enabled=yes require-client-certificate=yes
/interface pptp-server server
set enabled=yes
/interface sstp-server server
set default-profile=default-encryption enabled=yes
/ip address
add address=192.168.0.1/24 comment=LAN1 interface=ether2 network=192.168.0.0
/ip arp
add address=192.168.0.5 comment=SERVER interface=bridge1 mac-address=70:8B:XX:XX:XX:XX
add address=192.168.0.6 comment=HTPC-LR interface=bridge1 mac-address=BC:5F:XX:XX:XX:XX
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add comment="ABB WAN" dhcp-options=hostname,clientid interface=ether1
/ip dhcp-server lease
add address=192.168.0.11 comment="SMA SOLAR INVERTER" mac-address=00:40:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.4 client-id=1:50:c7:XX:XX:XX:XX comment="TP-LINK AP (GF)" mac-address=50:C7:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.3 client-id=1:50:c7:XX:XX:XX:XX comment="TP-LINK AP (1STF)" mac-address=50:C7:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.12 client-id=1:0:5:XX:XX:XX:XX comment="DENON AMP" mac-address=00:05:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.9 client-id=1:24:5e:XX:XX:XX:XX comment="QNAP NAS" mac-address=24:5E:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.2 client-id=1:b0:4e:XX:XX:XX:XX comment="TP-LINK SWITCH" mac-address=B0:4E:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.16 client-id=1:cc:d3:XX:XX:XX:XX comment="MAXXTV (D/S)" mac-address=CC:D3:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.5 client-id=1:70:8b:XX:XX:XX:XX comment=SERVER mac-address=70:8B:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.6 client-id=1:bc:5f:XX:XX:XX:XX comment=HTPC-LR mac-address=BC:5F:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.8 client-id=1:3c:2a:XX:XX:XX:XX comment="BROTHER PRINTER" mac-address=3C:2A:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.13 client-id=1:f4:7b:XX:XX:XX:XX comment="SAMSUNG-TV" mac-address=F4:7B:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.14 client-id=1:e4:7c:XX:XX:XX:XX comment="SAMSUNG-TV" mac-address=E4:7C:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.15 client-id=1:cc:d3:XX:XX:XX:XX comment="MAXXTV (U/S)" mac-address=CC:D3:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.17 client-id=1:18:68:XX:XX:XX:XX comment="HIKVISION NVR" mac-address=18:68:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.19 client-id=1:b8:27:XX:XX:XX:XX comment="RPi [WIFI]" mac-address=B8:27:XX:XX:XX:XX server="DHCP LAN1"
add address=192.168.0.18 client-id=1:b8:27:XX:XX:XX:XX comment=RPi mac-address=B8:27:XX:XX:XX:XX server="DHCP LAN1"
/ip dhcp-server network
add address=192.168.0.0/24 comment=LAN1 gateway=192.168.0.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.0.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment="accept established, related, untracked" connection-state=established,related,untracked
add action=accept chain=input comment="accept OpenVPN" dst-port=1194 protocol=tcp
add action=accept chain=input comment="accept ROUTER (SSH)" dst-port=11122 protocol=tcp
add action=accept chain=input comment="accept ROUTER SSL" dst-port=11443 protocol=tcp
add action=accept chain=input comment="accept ROUTER WINBOX" dst-port=8291 protocol=tcp
add action=accept chain=input comment="accept ICMP" protocol=icmp
add action=accept chain=forward comment="accept IN IPSEC policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="accept OUT IPSEC policy" ipsec-policy=out,ipsec
add action=accept chain=input comment="accept IPsec NAT" dst-port=4500 protocol=udp
add action=accept chain=input comment="accept IKE" dst-port=500 protocol=udp
add action=accept chain=input comment="accept l2tp" dst-port=1701 protocol=udp
add action=drop chain=input comment="drop invalid" connection-state=invalid
add action=drop chain=input comment="drop all not coming from LAN" in-interface-list=!LAN
add action=fasttrack-connection chain=forward comment=fasttrack connection-state=established,related
add action=accept chain=forward comment="accept established, related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="drop invalid" connection-state=invalid
add action=drop chain=forward comment="drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment=masquerade disabled=yes ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment=masquerade ipsec-policy=out,none out-interface=lte1
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=192.168.89.0/24
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh port=11122
set www-ssl certificate=https-cert disabled=no port=11443
/ip smb
set comment=Mikrotik domain=WORKGROUP enabled=yes
/ip smb users
add name=admin read-only=no
/ip ssh
set allow-none-crypto=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge1 type=internal
add interface=ether1 type=external
/ipv6 address
add address=::ba69:XXXX:XXXX:XXXX eui-64=yes from-pool=abb interface=bridge1
/ipv6 dhcp-client
add add-default-route=yes interface=ether1 pool-name=abb pool-prefix-length=56 request=address,prefix
/ipv6 firewall address-list
add address=fe80::/16 list=allowed
add address=ff02::/16 comment=multicast list=allowed
add list=allowed
/ppp secret
add name=admin profile=ovpn-profile service=ovpn
add name=admin profile=l2tp-profile service=l2tp
add name=vpn
/system clock
set time-zone-name=Australia/Melbourne
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Thanks.

Who is online

Users browsing this forum: No registered users and 40 guests