Community discussions

 
issathi
just joined
Topic Author
Posts: 4
Joined: Tue Apr 16, 2019 9:50 pm

Problems with BitTorrent

Tue Apr 16, 2019 10:20 pm

Hi, first of all, this is the first MikroTik router i have. Before that i had TP-Link TL-WR1043ND as my main router (it was connected to my ISP's "modem") and i used TP-Link TL-WR741ND as repeater to connect my desktop to internet.

I use qBittorrent and seed more than 350 multi file torrents. With my TP-Link "setup" everything was fine, i could seed and use my internet comfortably (netflix, online games.....).

I decided to replace the WR1043ND, mostly because of security concerns (it was last updated by TP-Link several years ago).

Well i bought the RB941-2nD, after several days of dinging around, I made the router to work as i wanted. The problem is that it can't handle the bittorrent load, after an our or so seeding internet becomes very slow and unusable. After i restart the router everything becomes normal, for an hour or so.

PS. As you noticed I'm not that technical.
PSS. English is not my native language.
 
anav
Forum Guru
Forum Guru
Posts: 2936
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Problems with BitTorrent

Wed Apr 17, 2019 5:52 pm

Well, the best thing to do is post your config and then we can see if there any particular reasons for the slow down.

/export hide-sensitive file=yourconfig
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
Paternot
Long time Member
Long time Member
Posts: 593
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: Problems with BitTorrent

Wed Apr 17, 2019 9:12 pm

Take a look at system -> resources, before the problem and after it.

We want to see memory and CPU usage. This unit is rater weak, and has only 32MB of RAM. With that many connections, conntrack may be eating all your RAM.
 
issathi
just joined
Topic Author
Posts: 4
Joined: Tue Apr 16, 2019 9:50 pm

Re: Problems with BitTorrent

Thu Apr 18, 2019 12:30 am

Hi, thanks for your replies!

anav - i attached the file, is it what you want ? )

Paternot - CPU load is 6%-30%, free memory 7.9-6.0Mb. Its like this before the problem and after it.
You do not have the required permissions to view the files attached to this post.
 
Paternot
Long time Member
Long time Member
Posts: 593
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: Problems with BitTorrent

Thu Apr 18, 2019 3:34 am

Hi, thanks for your replies!

anav - i attached the file, is it what you want ? )

Paternot - CPU load is 6%-30%, free memory 7.9-6.0Mb. Its like this before the problem and after it.
Weird, it should work. CPU load is light, and memory is not exhausted. Your firewall rules are quite standard too. Are you sure it started with the Mikrotik? Could it be a coincidence? If it seeds ok for about one hour, we know it can handle the load. Nothing on logs?
 
issathi
just joined
Topic Author
Posts: 4
Joined: Tue Apr 16, 2019 9:50 pm

Re: Problems with BitTorrent

Thu Apr 18, 2019 10:47 am

Before Mikrotik everything was ok.

One more thing, see the photos i attached, they are from Wireless->WiFi Interfaces-> wlan1->Traffic. I guess it should not be like that, the drops I mean.
You do not have the required permissions to view the files attached to this post.
 
vilpalu
just joined
Posts: 13
Joined: Mon Feb 12, 2018 1:04 pm

Re: Problems with BitTorrent

Thu Apr 18, 2019 11:14 am

from gigabit performance to 100mbps performance... You cant complain about it, becouse your router is too weak, try something like HEX.
 
issathi
just joined
Topic Author
Posts: 4
Joined: Tue Apr 16, 2019 9:50 pm

Re: Problems with BitTorrent

Thu Apr 18, 2019 12:14 pm

Hi vilpalu.
My internet speed is not that high (~30 Mbps/15-20 Mbps).

Several years ago I had 2 TL-WR741ND (one was used instead of TL-WR1043ND) and everything was working fine.
So this device can't even compete in performance with TL-WR741ND?
 
R1CH
Forum Veteran
Forum Veteran
Posts: 883
Joined: Sun Oct 01, 2006 11:44 pm

Re: Problems with BitTorrent

Thu Apr 18, 2019 1:35 pm

Mikrotik wifi performance is often worse than competitor devices due to outdated kernel and proprietary drivers. That said it shouldn't drop out completely like this. Is the device possibly overheating?

I would suggest trying 20 Mhz channel, g/n only, enable WMM and set group key update to 1h (security profile).

Who is online

Users browsing this forum: No registered users and 35 guests