Community discussions

MikroTik App
 
lrn23
newbie
Topic Author
Posts: 30
Joined: Mon Jan 07, 2019 10:24 am

RB3011 switch chip hw offload VLAN configuration

Tue Apr 30, 2019 1:09 pm

Hello,
I'm a little bit lost. I have to configure RB3011UiAS running ROS 6.44. I'm trying to configure it with a switch and use hardware offloading.

I need to configure:
ether1 - gateway (internet)
ether5 - hybrid port - tagged VLAN 20,30 + untagged VLAN 1
ether6 - untagged VLAN 1
ether7 - untagged VLAN 1
ether8 - untagged VLAN 1
ether9 - untagged VLAN 1

On port ether5 there is a Ubiquiti switch and APs. I need to have there tagged VLANs for guests and untagged VLAN 1 for management.
On other ports there is a computer on ether9, where I have UniFi controller and WinBox for configuring RB and switch + APs.

Here is my configuration:
/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether5 hw=yes
add bridge=bridge1 interface=ether6 hw=yes
add bridge=bridge1 interface=ether7 hw=yes
add bridge=bridge1 interface=ether8 hw=yes
add bridge=bridge1 interface=ether9 hw=yes

/interface ethernet switch vlan
add ports=ether5 switch=switch2 vlan-id=20
add ports=ether5 switch=switch2 vlan-id=30

/interface ethernet switch port
set ether5 vlan-mode=secure vlan-header=leave-as-is default-vlan-id=1
set ether6 vlan-mode=secure vlan-header=leave-as-is default-vlan-id=1
set ether7 vlan-mode=secure vlan-header=leave-as-is default-vlan-id=1
set ether8 vlan-mode=secure vlan-header=leave-as-is default-vlan-id=1
set ether9 vlan-mode=secure vlan-header=leave-as-is default-vlan-id=1

/ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1
/ip address add address=192.168.1.253/255.255.255.0 interface=bridge1 disabled=no

/ip pool add name=pool1 ranges=192.168.1.100-192.168.1.200
/ip dhcp-server add name=server1 interface=bridge1 address-pool=pool1
/ip dhcp-server enable server1
/ip dhcp-server network add address=192.168.1.0/255.255.255.0 gateway=192.168.1.253 netmask=255.255.255.0 dns-server=8.8.8.8

Where to put switch2-cpu? I need to put it somewhere to be able to manage RB from untagged VLAN 1 am I right?
Also I'm a little bit confused in case of vlan-mode and vlan-header options :-/

Any help would be greatly appreciated! Thank you!
Last edited by lrn23 on Tue Apr 30, 2019 3:32 pm, edited 1 time in total.
 
User avatar
mkx
Forum Guru
Forum Guru
Posts: 11621
Joined: Thu Mar 03, 2016 10:23 pm

Re: RB3011 switch chip hw offload VLAN configuration  [SOLVED]

Tue Apr 30, 2019 3:16 pm

Whatever passes wire untagged doesn't have any particular tag kn either side. I'm guessing Ubiquiti is calling "untagged VLAN 1" what is simply "untagged" and should be treated like such in Mikrotik.

So you're getting the untaggedstuff to the bridge already. For the tagged stuff, change your config to this:
/interface ethernet switch vlan
add ports=ether5,switch2-cpu switch=switch2 vlan-id=20
add ports=ether5,switch2-cpu switch=switch2 vlan-id=30
Leave out the default-vlan-id=1 from switch port setup.

Do you need routing for VKANs 20 and 30? If so, you'll need appropriate interfaces so zhat router will interact with those subnets:
/interface vlan
add interface=bridge1 name=vlan20 vlan-ids=20
add interface=bridge1 name=vlan30 vlan-ids=30
You then add IP address to interfaces vlan20 and vlan30.

Your current IP setup for untagged (VLAN1?) is not consistent. You have IP address bound on ether1, which doesn0t seem to be member of any bridge. But you have DHCP server with settings corresponding that subnet, bound to bridge (untagged).

For meaning of vlan-mode and vlan-header ... read up description, possibly speciffic to your device (there are slight differences between some devices).
 
lrn23
newbie
Topic Author
Posts: 30
Joined: Mon Jan 07, 2019 10:24 am

Re: RB3011 switch chip hw offload VLAN configuration

Tue Apr 30, 2019 3:40 pm

Oh, ok. thank you very much! I'll try it imidiatelly! :)

And yes, there was a typo. IP address is on bridge1. Ether1 and not mentioned ether2 are gateways.

Who is online

Users browsing this forum: iaming, jaclaz, jajo10, johnson73, KpuCko, mwm1x and 120 guests