Community discussions

User avatar
Topic Author
Posts: 38
Joined: Sun Feb 22, 2015 12:12 pm
Location: Amsterdam, Netherlands

iframe issue at MTU 1500

Wed May 15, 2019 6:59 pm

Hi guys,

Today I have runned into a weird issue at a clients network. We have a fiber connection onsite with a pppoe connection that supports RFC4638/MTU 1500 frames. Since we deliver a multitenant network each client is hosted in its own vlan.

Today a client reported issues with a squarespace website with an iframe that wouldn't load within the squarespace website. The source website that delivers the content and iframe is accessible directly. However the iframe within the squarspace website provides a no-load error. When I connect to my android hotspot or to my personal sstp gateway at home (Mtu 1400), the iframe will load.

Changing the MSS in mangle to 1400 or 1300 doesn't help to get this iframe loading. I also tried manually lowering the MTU on the PPPoE and cheking if the pppoe profile would allow changing MSS changes.Nothing worked.

Any pointers or suggestions?

Thanks! Alex
User avatar
Forum Veteran
Forum Veteran
Posts: 901
Joined: Tue Oct 11, 2005 4:53 pm

Re: iframe issue at MTU 1500

Mon May 20, 2019 3:35 am

What does the browser's web developer's tools console shows when it cannot load the iframe?

If the iframe url can load when accessed directly, then it's almost certain that it is not a networking/MTU/MSS issue.

Is it possible that the client's browser is messed up (or some other software is messing with it) causing it to not load?

Who is online

Users browsing this forum: No registered users and 8 guests