Community discussions

 
User avatar
Steveocee
Forum Guru
Forum Guru
Topic Author
Posts: 1034
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

How to PCQ this?

Wed May 15, 2019 8:01 pm

Hi,
I just can't get my head around using PCQ to do what I want. Any help would be appreciated.
This is for my internet connection which is a PPPoE client and I am using an SFQ rule as follows:
/queue simple
add max-limit=55M/16M name=WAN_CONTROL queue=default-sfq/default-sfq target=pppoe-out1
All I want to do is apply a PCQ to that where the router allocates the bandwidth per client. My understanding is that the pcq-rate would =0 for this to happen? Just where and how do I do that?
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials
 
User avatar
Steveocee
Forum Guru
Forum Guru
Topic Author
Posts: 1034
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: How to PCQ this?

Wed May 15, 2019 8:06 pm

OK, This is working as far as I speedtest from my PC and I can see the queue hitting limits. So it's correct in that it works, but is it correct in it's implementation?
/queue simple
add max-limit=55M/16M name=WAN_PCQ queue=pcq-download-default/pcq-upload-default target=pppoe-out1
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1258
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: How to PCQ this?

Wed May 15, 2019 11:50 pm

Target should point to internal subnet, rest looks good
MTCNA, MTCTCE, MTCRE & MTCINE
 
User avatar
Steveocee
Forum Guru
Forum Guru
Topic Author
Posts: 1034
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: How to PCQ this?

Thu May 16, 2019 10:53 am

Target should point to internal subnet, rest looks good
I have 3 internal subnets so would that still work? If rather keep it a simple queue if I can, I know I could mangle & mark but if rather try to keep it simple.
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1258
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: How to PCQ this?

Thu May 16, 2019 10:10 pm

Are the subnets consecutive? If so, aggregate / summarize the subnets
MTCNA, MTCTCE, MTCRE & MTCINE
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1581
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: How to PCQ this?

Fri May 17, 2019 5:13 pm

when defining queues / limits / ... upload is first: queue=<up>/<down>

another option for multiple ranges: use parent queue with the limits defined there

Who is online

Users browsing this forum: Google [Bot] and 57 guests