Community discussions

 
texmeshtexas
newbie
Topic Author
Posts: 36
Joined: Sat Oct 11, 2008 11:17 pm

DNS and Radius random failures

Mon May 27, 2019 8:10 pm

Ok, This is a strange one and hard to reproduce.

Symptom: PPPoE authentications are failing against our off site Radius server.
We can reboot the router and everything is fine again.

During investigation and while the router was in the state, I looked to see if there was a more current version of RouterOS and noticed that DNS would fail.
When I tried running
:put [resolve google.com] the result was Failure: dns server failure.
So I looked at the DNS settings

# may/27/2019 11:54:34 by RouterOS 6.44.3
# software id = Q018-HVJF
#
# model = CCR1009-8G-1S
# serial number = 5D920475E35E
/ip dns
set allow-remote-requests=yes cache-max-ttl=30m cache-size=32768KiB \
max-concurrent-queries=2000 max-concurrent-tcp-sessions=1000 \
max-udp-packet-size=1024 servers=10.200.0.8,10.200.0.14

I added a third DNS server of 8.8.8.8 and that did not make any difference.

Next, I set allow-remote-requests=no
The DNS resolve now works.
Then I set allow-remote-requests=yes
The DNS resolve continued to work. But would fail again within about 30min

If I reboot the router, all is good for several days to a week.

This is occurring on several routers across our network randomly.

I’m confused as to why the initial reported problem was Radius Auth failures because Radius severs are using IPs not URL names to access our server.
I think this is some underlying issue that is manifesting itself in Radius operations as well as DNS operations.

Anybody see this?

Who is online

Users browsing this forum: No registered users and 112 guests