Community discussions

 
cainram
just joined
Topic Author
Posts: 1
Joined: Tue May 28, 2019 9:42 pm

DHCP Option 82 with Ubiquiti Radios

Tue May 28, 2019 10:06 pm

I'm new to MikroTik and RouterOS and I'm having trouble with DHCP Option 82. I'm working at a WISP and we have both our CPE radios and the APs on the towers configured as bridges. Our provisioning/billing system uses address lists and queues to shape traffic to each user based upon their service tier. This works well in the lab but requires a MAC and IP to throttle. Having the CPE in bridged mode means that the MikroTik only knows about the customer's router. I would like to use option 82 so that I can give the customer provided router an IP address but still have my provisioning software know about the MAC of the bridged radio (Remote ID per option 82) so the IP address handed out by the MikroTik can be associated with the customer's account and the speeds can be managed accordingly.

My lab setup is simple: MikroTik RB2011UiAS with DHCP server --> Ubnt Nano Loco bridged Access Point PtMP --> Ubnt Nano Loco bridged station --> laptop

I get an address from the MikroTik no problem. Then I turn on option 82 in the CPE side radio and I cannot pull an address. I see nothing in the log and it appears as though the MIkroTik isn't getting anything from the client. I have been informed that some have gotten this working but have had to play around with different combinations of having option 82 turned on in just the client/just the AP/both. I have tried all combinations to no avail.

Once I can get the MikroTik to assign an address to the laptop with Option 82 turned on the next step is to put the provided script into the MikroTik to pass the DHCP leases to the provisioning server. One of my concerns is that there isn't a column for 'Remote ID' in the Leases tab of the DHCP Server window in WinBox...

If anyone has something I could try or knows of something I'm missing I would be willing to try anything.
 
pmurdock
newbie
Posts: 32
Joined: Sun Jul 03, 2005 7:39 am
Location: Herriman, Utah
Contact:

Re: DHCP Option 82 with Ubiquiti Radios

Sun Jul 28, 2019 1:22 am

Did you ever find a solution to this problem?

I have determined that the Mikrotik DHCP server fails to work if the Ubiquiti AP has DHCP option 82 on.
 
pmurdock
newbie
Posts: 32
Joined: Sun Jul 03, 2005 7:39 am
Location: Herriman, Utah
Contact:

Re: DHCP Option 82 with Ubiquiti Radios

Tue Oct 08, 2019 9:42 pm

I have this same problem.. As soon as DHCP82 is turned on, on the radio the client hardware past the AirMax AC radios can no longer pull DHCP addresses.. It doesn't seem to happen to all routers, but some routers seem to struggle with it.

Who is online

Users browsing this forum: Bing [Bot], MSN [Bot] and 10 guests