Community discussions

 
UpRunTech
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Fri Jul 27, 2012 12:11 pm

Tip on using PCQ for low bandwidth links

Wed May 29, 2019 10:59 am

I have been stuck on a crummy ADSL2 service that has a crummy inconsistent 5-10Mbit down 1Mbit up speed for a long time. A quick read of how FQ-codel works with dynamically monitoring and adjusting internal buffer parameters got me wondering how buffer size adjustment with a feedback loop somehow could be emulated or implemented using existing queues in Mikrotik.

In the end I just messed with PCQ buffer size settings and arrived at ones that seem to give good browsing responsiveness for other users even when heavy saturating upload and download is occurring. There is no feedback loop but maybe something could be done with scripting - I am not sure though because there is no way for a script to get insight into how the buffers are performing

Below are the two PCQ settings I use in my simple queues (I have never used queue trees to date - simple ones work well enough). I haven't been scientific about it but they work and feel better than that default PCQ settings. Obviously making the queue buffers as small as need be works well and PCQ ensures that no one queue dominates.

Code: Select all

/queue type
add kind=pcq name=pcq-upload-adsl pcq-classifier=src-address,src-port \
pcq-limit=2KiB pcq-total-limit=1000KiB
add kind=pcq name=pcq-download-adsl pcq-classifier=dst-address,dst-port \
pcq-limit=20K

Who is online

Users browsing this forum: Google [Bot], MSN [Bot] and 82 guests