Community discussions

 
qcx1923
just joined
Topic Author
Posts: 1
Joined: Tue May 14, 2019 7:31 pm

Cannot unset default-vlan-id

Sat Jun 08, 2019 5:51 pm

I have a couple of new RB1100AHx4 with ROS 6.43 (LTS). They both came with a default config which included the following lines:

/interface ethernet switch port
set 0 default-vlan-id=0
set 1 default-vlan-id=0
set 2 default-vlan-id=0
set 3 default-vlan-id=0
set 4 default-vlan-id=0
set 5 default-vlan-id=0
set 6 default-vlan-id=0
set 7 default-vlan-id=0
set 8 default-vlan-id=0
set 9 default-vlan-id=0
set 10 default-vlan-id=0
set 11 default-vlan-id=0
set 12 default-vlan-id=0
set 13 default-vlan-id=0
set 14 default-vlan-id=0
set 15 default-vlan-id=0

I cannot get rid of these lines. I have tried CLI, WinBox, WebFig. Complete factory reset, etc. From only the CLI, I can change the default-vlan-id numbers, but not remove them. The switch port page in WinBox/WebFig gives me an error whatever I do. Even if I try to save the page with no changes! So the CLI believes the existing config is an error?

Is it impossible to NOT use VLANs?

I tried to ignore this and go on, but it appears that the RB is forwarding L2 packets to all ports regardless of actual network config. How can any router operate with all ports in a forced bridge?

My config I need 3 ports, WAN, LAN, and OOB MGMT. I do not use tagged VLANs. Routing only, no firewall except to protect the device itself. Public IPs on both sides, so NAT, DHCP, etc. For now just the single router. I have implemented this exact router position on hardware from 3 different vendors previously, from Ubiquiti to Cisco. It should very simple routing setup.

On any other router this would be easy with no forced bridge-all config. On switches I isolate the OOB MGMT network port with a hard VLAN. On routers it is normally not necessary because they only forward what they are told to. The MGMT net is not routed anywhere. The admin servers have interfaces directly on this network.

So from here on it gets even more messy. Obviously the RB1100AHx4 has 3 of the RTL8367 switch chips. I tried dividing into 3 default-vlan-ids by switch chip. No joy.

I have tried:
Individual ports
bridges the "new way"
bridges the "old way"
vlans on bridges
vlans on individual ports
bridges without vlans
No firewall filters
Strict firewall filters
loose firewall filters
Firewall filters on the input chain only
I tried dropping all filters, including input chain, in the lab

The non-documentation gets really messy with several different ways to do things based on various obsolete software and different hardware. There are references to current software with other hardware. References to this hardware with unspecified (but clearly older) software. Nothing is up-to-date for this current combination.

Without hard VLANs, I get all the expected effects of L2 loops, STP/RSTP/MSTP problems, forwarding to strange places, etc. With every VLAN setup I have tried I get errors and/or no forwarded traffic.

This is getting completely ridiculous. I have to believe Mikrotik is actually capable of basic operation or they wouldn't be used as much as they are.

What gives? What is the correct way to make a basic routing configuration?
 
sindy
Forum Guru
Forum Guru
Posts: 3811
Joined: Mon Dec 04, 2017 9:19 pm

Re: Cannot unset default-vlan-id

Mon Jun 10, 2019 7:54 pm

VLAN ID 0 means to treat the packet as untagged, plus to take the default-vlan-id into account at all, other settings need to be activated on the switch chip. So if you don't need VLANs or switching/bridging, just remove the interfaces from any bridges and attach the IP configurations directly to them.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.

Who is online

Users browsing this forum: Google [Bot] and 115 guests