Community discussions

 
bronx
newbie
Topic Author
Posts: 39
Joined: Wed Feb 11, 2015 1:04 am
Location: Turin, Italy

Interface packets discard.

Mon Jun 10, 2019 12:34 am

Hello guys,

N00b question here =)

I'm trying to understand when my router discards packets (e.g. the output interfaces cannot handle more traffic).

As you can see in the attachment, I was sending 25Mbps from ether1 inside the router, that was expected to be routed out on pppoe-dati (that it's attached on wlan1).

Unfortunately wlan1 can handle just ~10Mbps, and as you can see in the attached picture, the router is blackholing ~14Mbps of traffic.

I was expecting the counters rx/tx-drop to increase on one of the interfaces involved but nothing happened :-(.

Do someone know where are the counters that I'm looking for?

Thanks =)
Screenshot 2019-06-09 22.10.19.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1776
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Interface packets discard.

Tue Jun 11, 2019 12:39 pm

Looks to me like traffic is going to pppoe-dait (internet?) from ether1 (lan?). Download probably. No drops. -> upload
Last edited by sebastia on Fri Jun 14, 2019 11:22 am, edited 1 time in total.
 
sindy
Forum Guru
Forum Guru
Posts: 3811
Joined: Mon Dec 04, 2017 9:19 pm

Re: Interface packets discard.

Tue Jun 11, 2019 12:55 pm

Looks to me like traffic is going from pppoe-dait (internet?) to ether1 (lan?). Download probably. No drops.
As the OP says pppoe-dait uses wlan1 as transport interface, it doesn't seem plausible unless there was some mysteriously efficient compression. Is compression set to yes in the ppp profile?
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1776
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Interface packets discard.

Tue Jun 11, 2019 2:12 pm

right. any queueing in place which limits the traffic?

Or just post your config: /export hide-sensitive compact...
Last edited by sebastia on Wed Jun 12, 2019 12:10 am, edited 1 time in total.
 
bronx
newbie
Topic Author
Posts: 39
Joined: Wed Feb 11, 2015 1:04 am
Location: Turin, Italy

Re: Interface packets discard.

Tue Jun 11, 2019 6:43 pm

No queue configured :-)

It's simply the interface wlan1 that it's not able to dequeue from the interface queue as fast as pppoe-dati is fillling it :-)


I will double check the configuration of the pppoe but I doubt that compression is enabled.

Just to be clear, my laptop was connected to ether1 and was generating traffic towards a destination reachable via pppoe-dati (that is attached to wlan1)
 
bronx
newbie
Topic Author
Posts: 39
Joined: Wed Feb 11, 2015 1:04 am
Location: Turin, Italy

Re: Interface packets discard.

Wed Jun 12, 2019 12:08 am

No queues e no compression enabled :-)
 
bronx
newbie
Topic Author
Posts: 39
Joined: Wed Feb 11, 2015 1:04 am
Location: Turin, Italy

Re: Interface packets discard.

Thu Jun 13, 2019 12:31 am

Code: Select all

/interface ethernet
set [ find default-name=ether1 ] comment=""
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode ampdu-priorities=0,1,2,3,4,5,6,7 band=5ghz-a/n \
disabled=no ht-supported-mcs=\
mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15\
rate-set=configured ssid=yeah supported-rates-a/g=\
6Mbps,9Mbps,12Mbps,18Mbps,24Mbps
/interface pppoe-client
add add-default-route=yes allow=pap disabled=no interface=wlan1 keepalive-timeout=60 max-mru=1450 max-mtu=1450 mrru=1614 \
name=pppoe-dati use-peer-dns=yes user=user
/interface list
add exclude=dynamic name=discover
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des
/ppp profile
set *0 use-compression=no use-encryption=no
/snmp community
set [ find default=yes ] addresses=0.0.0.0/0
add addresses=0.0.0.0/0 name=test security=authorized
/system logging action
set 0 memory-lines=100
set 1 disk-lines-per-file=100
/interface bridge settings
set use-ip-firewall=yes use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes
/ip neighbor discovery-settings
set discover-interface-list=discover
/ipv6 settings
set max-neighbor-entries=1024
/interface list member
add interface=ether1 list=discover
add interface=wlan1 list=discover
/interface wireless snooper
set receive-errors=yes
/ip address
add address=192.168.7.1/30 interface=ether1 network=192.168.7.0
/ip dns
set servers=10.5.0.1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-dati
/ip proxy
set cache-path=web-proxy1 parent-proxy=0.0.0.0
/ip route
add distance=1 dst-address=192.168.0.0/24 gateway=192.168.7.2
add distance=1 dst-address=192.168.3.0/24 gateway=192.168.7.2
add distance=1 dst-address=192.168.6.0/24 gateway=192.168.7.2
add distance=1 dst-address=192.168.10.0/24 gateway=192.168.7.2
/ipv6 dhcp-client
add interface=pppoe-dati pool-name=pool-ipv6-delegation request=prefix
/radius
add address=1.2.3.4 service=login
/snmp
set contact=Me enabled=yes location="" trap-community="" trap-target="" trap-version=3
/system clock
set time-zone-name=Europe/Rome
/system identity
set name="Cpe"
/system leds
set 0 interface=ether1 leds=user-led type=interface-activity
/system logging
add topics=wireless
/system ntp client
set enabled=yes primary-ntp=193.204.114.232 secondary-ntp=193.204.114.233
/tool graphing interface
add interface=ether1
add interface=pppoe-dati
/user aaa
set default-group=full use-radius=yes
 
bronx
newbie
Topic Author
Posts: 39
Joined: Wed Feb 11, 2015 1:04 am
Location: Turin, Italy

Re: Interface packets discard.

Fri Jun 14, 2019 1:05 am

Any ideas? :-)
 
bronx
newbie
Topic Author
Posts: 39
Joined: Wed Feb 11, 2015 1:04 am
Location: Turin, Italy

Re: Interface packets discard.

Sun Jun 23, 2019 6:18 am

:-(
 
bronx
newbie
Topic Author
Posts: 39
Joined: Wed Feb 11, 2015 1:04 am
Location: Turin, Italy

Re: Interface packets discard.

Sat Oct 05, 2019 12:07 am

This looks like a bug.

How can I report it?

Who is online

Users browsing this forum: No registered users and 103 guests