Community discussions

 
pingu8007
just joined
Topic Author
Posts: 1
Joined: Mon Jun 10, 2019 9:26 am

No dhcpoffer under second interface of bridge

Mon Jun 10, 2019 9:49 am

I'm configure an RouterOS inside Hyper-V VM, and I got problem to make devices under SECOND PORT receive DHCP offer.

I start from clean vhdx image with 4 interfaces: 1 for upstream, 1 for management, and 1 bridge with 2 interfaces for all downstream devices. After bridge created I found DHCP clients from second port (ether4) always stuck in offered while devices under first port (ether3) bound without issues. Same DHCP clients work fine after exchanging ports from Hyper-V.

I have read that interfaces bound to bridge are treated as parts of it and everything depend on how the bridge configured, so I have no idea how does it happen. Here is the configuration:

Code: Select all

[admin@MikroTik] > export
# jun/10/2019 14:18:02 by RouterOS 6.44.3
# software id =
#
#
#
/interface ethernet
set [ find default-name=ether1 ] comment=Host disable-running-check=no
set [ find default-name=ether2 ] comment=Upstream disable-running-check=no
set [ find default-name=ether3 ] comment=LAN-AP disable-running-check=no
set [ find default-name=ether4 ] comment=LAN-VM disable-running-check=no
/interface bridge
add name=internal-br
/ip pool
add name=internal-ip ranges=172.16.1.1-172.16.1.253
/ip dhcp-server
add address-pool=internal-ip disabled=no interface=internal-br lease-time=1w name=internal-dhcp
/dude
set enabled=yes
/interface bridge port
add bridge=internal-br interface=ether3
add bridge=internal-br interface=ether4
/ip address
add address=172.16.0.1/16 interface=internal-br network=172.16.0.0
add address=192.168.172.1/24 interface=ether1 network=192.168.172.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether2
/ip dhcp-server lease
add address=172.16.0.2 client-id=1:0:d8:61:20:4f:c1 comment=WS2016 mac-address=00:D8:61:20:4F:C1 server=internal-dhcp
add address=172.16.0.10 client-id=1:50:f:f5:b2:68:0 comment=TendaAP mac-address=50:0F:F5:B2:68:00 server=internal-dhcp
/ip dhcp-server network
add address=172.16.0.0/16 gateway=172.16.0.1
/ip firewall nat
add action=masquerade chain=srcnat src-address=172.16.0.0/16
/system clock
set time-zone-name=Asia/Taipei

Who is online

Users browsing this forum: Bing [Bot] and 28 guests