Community discussions

 
pepelxl
just joined
Topic Author
Posts: 13
Joined: Tue Jul 23, 2013 6:59 pm

Loss of the first byte in at-chat.

Tue Jun 18, 2019 12:44 pm

Hi, I encountered data loss in at-chat with a Huawei modem.
Working sample in mode: /port firmware set ignore-directip-modem=yes
  MikroTik RouterOS 6.44.3 (c) 1999-2019       http://www.mikrotik.com/
[pepelxl@Dacha] > /system serial-terminal port=usb1 channel=4

[Ctrl-A is the prefix key]


ati
Manufacturer: Huawei Technologies Co., Ltd.
Model: ME909s-120
Revision: 11.617.09.00.00
IMEI: 359711070394787
+GCAP: +CGSM,+DS,+ES

OK
at+cmgl=4
+CMGL: 1,1,,134
07919781340310F14406D04DEA1000089160209080232176050003A104040433043E002004320020043F04400438043B043E04360435043D0438043800200022041C043E04390020041C042204210022
003A0020006D00740073002E00720075002F006100700070002004210020043704300431043E0442043E0439002C00200412043004480020041C04220421
+CMGL: 2,1,,156
07919781340310F14006D04DEA100008916030509213218C0500032F0201041F043E044004300020043F043E043F043E043B043D04380442044C002004410447043504420021002004110430043B0430
043D0441002004120430044804350433043E00200441044704350442043000200441043E0441044204300432043B044F04350442002000310035002C003000300020044004430431002E0020041B0435
0433043A
+CMGL: 3,1,,156
07919781340310F14006D04DEA100008916020908023218C050003A104020435043404410442043200200434043B044F00200441043F043804410430043D0438044F002004320442043E0440043E0439
002004470430044104420438002004300431043E043D0435043D04420441043A043E04390020043F043B04300442044B002004370430002004420435043A04430449043804390020043C04350441044F
0446002E
+CMGL: 4,1,,118
07919781340310F14406D04DEA10000891603050921321660500032F02020438043500200441043F043E0441043E0431044B0020043F043E043F043E043B043D04380442044C00200441044704350442
0020043D04300020044104300439044204350020006F0070006C006100740061002E006D00740073002E00720075
+CMGL: 5,0,,144
07919761980614F80406D04DEA1000089160318051512180041F043E044104420443043F0438043B0020043F043B0430044204350436002000310030003000300020044004430431002E00200421043F
0430044104380431043E002C002004470442043E0020043F043E043B044C043704430435044204350441044C002004430441043B044304330430043C04380020041C042204210021

OK
Problem sample mode: /port firmware set ignore-directip-modem=no
Loss of the first two bytes of new lines:
/ interface lte at-chat lte1 input = "ati"
  output: Manufacturer: Huawei Technologies Co., Ltd.
del: ME909s-120
vision: 11.617.09.00.00
EI: 359711070394787
CAP: + CGSM, + DS, + ES
Ok
Loss of the first byte of each message and loss of formatting:
/interface lte at-chat lte1 input="at+cmgl=4"
  output: +CMGL: 1,1,,134 919781340310F14406D04DEA1000089160209080232176050003A104040433043E002004320020043F04400438043B043E04360435043D0438043800200022041C04
          3E04390020041C042204210022003A0020006D00740073002E00720075002F006100700070002004210020043704300431043E0442043E0439002C00200412043004480020041C042204
          21 MGL: 2,1,,156 919781340310F14006D04DEA100008916030509213218C0500032F0201041F043E044004300020043F043E043F043E043B043D04380442044C00200441044704350
          4420021002004110430043B0430043D0441002004120430044804350433043E00200441044704350442043000200441043E0441044204300432043B044F04350442002000310035002C0
          03000300020044004430431002E0020041B04350433043A MGL: 3,1,,156 
          919781340310F14006D04DEA100008916020908023218C050003A104020435043404410442043200200434043B044F00200441043F043804410430043D0438044F002004320442043E04
          40043E0439002004470430044104420438002004300431043E043D0435043D04420441043A043E04390020043F043B04300442044B002004370430002004420435043A04430449043804
          390020043C04350441044F0446002E MGL: 4,1,,118 
          919781340310F14406D04DEA10000891603050921321660500032F02020438043500200441043F043E0441043E0431044B0020043F043E043F043E043B043D04380442044C0020044104
          47043504420020043D04300020044104300439044204350020006F0070006C006100740061002E006D00740073002E00720075 MGL: 5,1,,144 
          919761980614F80406D04DEA1000089160318051512180041F043E044104420443043F0438043B0020043F043B0430044204350436002000310030003000300020044004430431002E00
          200421043F0430044104380431043E002C002004470442043E0020043F043E043B044C043704430435044204350441044C002004430441043B044304330430043C04380020041C042204
          210021 OK
I understand that when switching mode, the modem automatically changes the layout of the ports.
In LTE, the modem sets: at ^ setmode = 3 (MBIM).
In directmode = yes, the modem sets at ^ setmode = 2 (Linux).
The equipment is in operation and stop for a full analysis is not possible. There is also a message from other users on the relevant forums about the same problem.
I bow to the incorrect operation of the ROS. Any suggestions for fixing the bug?

Who is online

Users browsing this forum: No registered users and 88 guests