Community discussions

 
User avatar
pdownen
just joined
Topic Author
Posts: 6
Joined: Tue Jun 18, 2019 7:20 pm
Location: St. Louis
Contact:

VoIP Outgoing Voice Issues - Seeking Guidance

Wed Jun 19, 2019 1:31 pm

UPDATE: Since my original post may be too long, here's the short of it:

Can anyone recommend a procedure or checklist for setting up small office VoIP using the MikroTik RB2011 and Router.OS?
Can you point me to any articles or other posts that provide solid, general guidance on troubleshooting outgoing voice quality problems?

thanks!

Phil

===============================
Disclaimer: I am and engineer but no expert at IT/VoIP set up and this is my first post to the forum. I apologize if I’ve not provided adequate information – please let me know if I can do better!

Problem Description: For the past several months, we’ve had voice quality issues on our company VoIP phones. There are three phones, but usually only one or two in use at a time (not a big bandwidth hog up or down). Other internet traffic is from several PCs on the LAN, but never anything heavy duty (no streaming up or down, no heavy uploads).

Most of the time, the audio quality is good (both directions), but intermittently suffers on the outgoing direction. Sometimes, the outside person can’t hear our inside person, or the audio is garbled to the outside person. Occasionally the calls drop / disconnect entirely.

We have a Charter Business ISP package: 100 Mbps Down / 10 Mbps Up and I’ve never done a Speed Test which didn’t come close to or exceed these expected speeds. Static IP.

Equipment (in order from ISP coax coming in):
1. CISCO “DPC3216 MTA” Cable Modem
2. MikroTik RB2011-iL-IN GigaBit Router
RouterOS v6.44.3 web interface
3. One Google WiFI Puck configured in Bridge Mode to avoid Double NAT
4. LAN equipment plugged into the Router via CAT6 cables:
Two HP PCs
Two ObiHai Obi1062 VoIP phones
5. On Google WiFi Access Point:
Two or three laptops PCs
Third ObiHai Obi1062 VoIP Phone
Two WiFi Printers
TCL LCD Smart TV in conference room
CAT 6 cables between Router and all listed LAN equipment

I’ve been reading a lot about SIP-ALG, Packet Latency/Collisions, QoS Prioritization, etc., but have not the confidence to try changes inside the Router. I did try disabling ‘sip’ but the outgoing audio quality problems persisted so I re-enabled it.

Charter Tech Support convinced me that their Modem showed no logged events of problems (outages, packets dropped) over the past 22 days or so…

We are using Google Voice Professional (a paid subscription) and Google Voice Tech Support has not been very helpful (they are asking us to do things we can’t do such as share the phone numbers of the people we are calling when the problem occurs, or to Duplicate the Problem (it’s a bit “random”).

Questions:
1. What should I look at inside the Router to confirm the outgoing audio is suffering from dropped packets or other transfer problems associated with poor audio quality or dropped calls?

2. Do I need to do anything first to assist with VoIP traffic troubleshooting (such as tagging VoIP data packets)? If so, what are the steps and what am I looking for?

3. Is there a standard QoS Optimization for VoIP that I can do within the Router that is fairly straight forward and proven? If so, what are the steps?

4. If this is not being caused by the Router or Phone configuration, what should I be asking the ISP to do/confirm/verify?

Any help or advice anyone can offer would be greatly appreciated. Thanks for your time in advance!

Phil
 
sindy
Forum Guru
Forum Guru
Posts: 3495
Joined: Mon Dec 04, 2017 9:19 pm

Re: VoIP Outgoing Voice Issues - Seeking Guidance

Fri Jun 21, 2019 6:10 pm

Intermittent issues are the worst to debug.

Since most of your calls has bidirectional audio and with no voice quality issues, you can forget about SIP ALG infulence.

The first thing to look at is the occasional garbled voice at the remote party as it occurs most frequently. As you don't experience garbled voice locally, the losses are not caused by overload of some of the routers. So I'd first of all have a look at the prioritization of the outgoing traffic, just to be sure that the issue doesn't happen during few periods of time when one of the devices in your LAN is heavily using the upload direction.

If you have no mangle rules in place and no queue settings yet, adapt it to your environment something like
/queue tree
add limit-at=9500k max-limit=9500k name=wan-parent parent=ether1 queue=ethernet-default
add limit-at=1M max-limit=9500k name=voip-out packet-mark=voip-out parent=wan-parent priority=1 queue=default
add limit-at=1M max-limit=9500k name=rest-out packet-mark=no-mark parent=wan-parent priority=2 queue=default

/ip firewall mangle
add action=mark-packet chain=postrouting new-packet-mark=voip-out out-interface=ether1 src-address=subnet.of.the.phones
If it doesn't help, convert your list of devices into a drawing showing the interconnection topology on the site.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
User avatar
pdownen
just joined
Topic Author
Posts: 6
Joined: Tue Jun 18, 2019 7:20 pm
Location: St. Louis
Contact:

Re: VoIP Outgoing Voice Issues - Seeking Guidance

Fri Jun 21, 2019 9:13 pm

Thanks, sindy. I appreciate your guidance and initial thoughts. I will try this script. I will study it more to understand all the functions and variables you've shown in the generic example. I may have a question about the placeholder names in the script that must be substituted with my actual WAN and LAN specifics...This is all new to me, so thanks for your kind patience and help.

kind regards,

Phil
 
User avatar
pdownen
just joined
Topic Author
Posts: 6
Joined: Tue Jun 18, 2019 7:20 pm
Location: St. Louis
Contact:

Re: VoIP Outgoing Voice Issues - Seeking Guidance

Sun Jun 30, 2019 9:35 pm

Hi sindy,

I'll be trying to run this script this week. Quick question - is it correct that the only thing I need to modify before running is the 'subnet.of.the.phones' variable?

Anything else that will be unique to my WAN/LAN set up that I'll need specific values for?

thanks for your help!

Phil
 
sindy
Forum Guru
Forum Guru
Posts: 3495
Joined: Mon Dec 04, 2017 9:19 pm

Re: VoIP Outgoing Voice Issues - Seeking Guidance

Sun Jun 30, 2019 9:42 pm

is it correct that the only thing I need to modify before running is the 'subnet.of.the.phones' variable?
Yes, that was the intention. This way each type of upload traffic should have its 1 Mbyte/s guaranteed and the rest be used by any of them with VoIP having priority.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
User avatar
pdownen
just joined
Topic Author
Posts: 6
Joined: Tue Jun 18, 2019 7:20 pm
Location: St. Louis
Contact:

Re: VoIP Outgoing Voice Issues - Seeking Guidance

Sun Jun 30, 2019 10:41 pm

Understood and thank you for your quick reply. I will be sure to report back after I run the script.

kind regards
 
Samot
Member Candidate
Member Candidate
Posts: 109
Joined: Sat Nov 25, 2017 10:01 pm

Re: VoIP Outgoing Voice Issues - Seeking Guidance

Mon Jul 01, 2019 5:09 am

What do tests from inside the network show? The ISP can tell you the modem hasn't had any dropped packets but that's the WAN, the LAN is also a factor here. VoIP can be fickle, when you start getting jitter and/or packet loss it can start to impact the call. Get to around 30% of the call goes to hell.
 
User avatar
pdownen
just joined
Topic Author
Posts: 6
Joined: Tue Jun 18, 2019 7:20 pm
Location: St. Louis
Contact:

Re: VoIP Outgoing Voice Issues - Seeking Guidance

Mon Jul 01, 2019 5:42 am

Hi Samot and thanks for chiming in!

The only testing I've done is the internet speed test, which I know is only a part of the story here...we've also swapped the three VoIP phones around and the quality issues always occur on the phone that gets the most use (makes sense for a pseudo-random event, I suppose).

After I run the script that sindy suggested, won't I be able to examine the VoIP packet performance since voice packets will be packet-marked (per the script)?

Any other suggestions on the tests I can do using Router.OS would be most appreciated!

Please forgive my ignorance on this subject - that's why I'm reaching out on the forum. I'll be happy to try anything you might suggest or provide data, results as needed.

thanks,

Phil
 
User avatar
pdownen
just joined
Topic Author
Posts: 6
Joined: Tue Jun 18, 2019 7:20 pm
Location: St. Louis
Contact:

Re: VoIP Outgoing Voice Issues - Seeking Guidance

Thu Jul 11, 2019 10:05 pm

Thanks sindy and Samot for your suggestions and guidance. I ran the Router.OS commands and rebooted the router to prioritize and tag VOip traffic. The voice quality problems persisted. Google tech support finally (after much back and forth with them) told us the ObiHai 1062 phones we use are, in fact, NOT compatible with Google Voice Professional Services. We have done a "soft confirm" of this hypothesis by using a USB headset with G.V. on one our our networked PC's. So far, it has performed flawlessly. So, we have ordered a new VOiP phone (touted as fully G.V. compatible - a Polycom VVX 350 OBI Edition IP Phone) to ensure compatibility before replacing all of the ObiHai 1062s. So it seems the problem was not with our ISP, the Modem, the Router, the Switch, the Cabling, or the G.V. configuration. The frustrating thing about this problem was that it was intermittent. Is VOiP technology supposed to be this hard to deploy? ; )

Thanks again, guys, for your assistance - it is much appreciated.

Phil

Who is online

Users browsing this forum: No registered users and 49 guests