Community discussions

MikroTik App
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 51
Joined: Thu Apr 05, 2007 5:51 pm

Routing, not bridging... how to?

Thu Apr 05, 2007 5:55 pm

Previously, I always worked with bridged interfaces, so routing in the same board is something new for me.

Suppose I have the next network configuration:

Clarkconnect gateway:
Mikrotik node #1:

Node is connected to gateway trought ethernet.

What routes must I create in the gateway and the node?

Thanks in advance!!
Member Candidate
Member Candidate
Posts: 294
Joined: Sun Apr 01, 2007 10:51 pm
Location: Christchurch, New Zealand

Fri Apr 06, 2007 12:44 am

Unfortuantely your post doesn't really contain enough information to give a precise answer.

As you don't specify the netmasks being used I'll have to second guess. I assume you're using ( on the Ethernet and 10.0.x.0/24 ( on the Wireless.

If you're using less than 24 bits on the Wireless then these will be bridged, not routed and you'd have to add a bridge to the MikroTik node and the ports to the bridge.

To start with your choice of addresses for the wireless interfaces would be better if they were:-


This makes routing a little neater and is a bit more logical.

Using a 24 bit netmask gives you up to 253 IP addresses free on each wireless, i.e. 10.0.x.0 is the network address, 10.0.x.255 is reserved as the broadcast address and 10.0.x.1 is the interface address, hence 256 - 3 = 253.

If you need more IP addresses then the netmask needs to be lower than 24 bits and this will change everything below. So decide how many addresses you need, if it is more than 253 per wireless card then reply to this post with the number you need and I'll update the information. I would have though 253 is more than enough, especially if you set the DHCP lease time to a low value, e.g. a couple of hours.

MikroTik Node

You need to add a 192.168.2.x address to the MikroTik node's ethernet interface.

Add a route for gateway to the MikroTik node.


You can either add one route on the gateway or 4 individual ones, which method you use will depend on whether you intend to use 10.x.x.x addresses elsewhere on your network.

The neatest way is to add one route for ( gateway 192.168.2.x, where x is the address you've allocated to the MikroTik ethernet interface.

Alternatively add 4 routes 10.0.n.0/24 ( gateway 192.168.2.x. (n is the incremental number given to each wireless interface).

If your gateway supports RIP then you could try that, however that's a whole new ball game and many domestic grade routers either don't support RIP at all or support it poorly.


Chris Macneill
Educated Guesswork Ltd. (
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 51
Joined: Thu Apr 05, 2007 5:51 pm

Fri Apr 06, 2007 1:44 am

Many thanks for your answer. Very clear and easy to understand :D
just joined
Posts: 12
Joined: Tue Apr 10, 2007 4:35 am

Router seems to have no connectivity between interfaces

Tue Apr 10, 2007 1:40 pm

Good evening, Chris -
Here's a question for you. I have an RB112 that has one ether1 port and (currently) one wireless interface called wlan1. I'm attempting to do a p2p link between two subnets and this is one end of that link.
I first did a Setup>r>y, so it's wiped clean.
I've followed the example on the wiki about transparently bridging two networks.
I've gotten myself into a situation where the two interfaces in the router are disconnected from one another, i.e., a ping from a computer connected to ether1 will see ether1 just fine, but cannot ping wlan1. Also, a device connected via the wds to wlan1 can ping the address but not the address.

[admin@MikroTik] ip route> print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf
0 ADC wds-bridge
1 ADC wds-bridge

Can you tell me what I'm doing wrong?

Thanks - Jon

Who is online

Users browsing this forum: nz_monkey, samwarez and 206 guests