Community discussions

 
Zoolander06
just joined
Topic Author
Posts: 16
Joined: Thu Jan 03, 2019 5:26 pm

No traffic in lan attached queue trees

Thu Jul 11, 2019 6:49 pm

Hello,

I usually use queue trees to prioritize VoIP traffic, and it works well.
But I have an issue with a rb2011 : there is absolutely no traffic going through queue trees attached to my lan interfaces.
I had this issue in the past because there was a "fast path" default rule, but on this router, I deleted it, so no fast path.
I don't understand why it doesn't work, could you help me please ?

Here is the configuration of the router :
# jul/11/2019 17:44:10 by RouterOS 6.44.3
# software id = BMAI-PUWW
#
# model = 2011UiAS-2HnD
# serial number = B9070A29E2A5
/interface bridge
add admin-mac=74:4D:28:87:88:9B auto-mac=no comment=defconf name=bridge
/interface ethernet
set [ find default-name=ether1 ] speed=100Mbps
set [ find default-name=ether2 ] speed=100Mbps
set [ find default-name=ether3 ] speed=100Mbps
set [ find default-name=ether4 ] speed=100Mbps
set [ find default-name=ether5 ] speed=100Mbps
set [ find default-name=ether6 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether7 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether8 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether9 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether10 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip,aes-ccm \
    management-protection=allowed mode=dynamic-keys name=wifi \
    supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    disabled=no distance=indoors frequency=auto mode=ap-bridge \
    security-profile=wifi ssid=Livebox-00bd wireless-protocol=802.11
/ip pool
add comment=LAN_DATA name=lan_data_pool ranges=192.168.1.10-192.168.1.150
add comment=LAN_VOIP name=lan_voip_pool ranges=192.168.250.10-192.168.250.20
/ip dhcp-server
add address-pool=lan_data_pool disabled=no interface=bridge name=\
    lan_data_dhcp
add address-pool=lan_voip_pool disabled=no interface=ether3 name=\
    lan_voip_dhcp
/ppp profile
add change-tcp-mss=yes name=ADSL use-compression=no use-encryption=no \
    use-mpls=no use-upnp=yes
/interface pppoe-client
add allow=pap,chap disabled=no interface=ether1 name=adsl-ether1 profile=ADSL \
    user=ip19051354538@srvc
/queue tree
add max-limit=900k name=upload-adsl parent=adsl-ether1 priority=1 queue=\
    default
add max-limit=1M name=upload-sdsl parent=ether2 priority=1 queue=default
add max-limit=8500k name=download-landata parent=bridge priority=1 queue=\
    default
add max-limit=8500k name=download-lanvoip parent=ether3 priority=1 queue=\
    default
add limit-at=500k max-limit=900k name=upload-voip-adsl packet-mark=VOIP-PKT \
    parent=upload-adsl priority=1 queue=default
add limit-at=500k max-limit=1M name=upload-voip-sdsl packet-mark=VOIP-PKT \
    parent=upload-sdsl priority=1 queue=default
add limit-at=500k max-limit=8500k name=download-voip-lanvoip packet-mark=\
    VOIP-PKT parent=download-lanvoip priority=1 queue=default
add max-limit=8500k name=donwload-std-lanvoip packet-mark=STD-PKT parent=\
    download-lanvoip queue=default
add max-limit=8500k name=download-std-landata packet-mark=STD-PKT parent=\
    download-landata queue=default
add max-limit=900k name=upload-std-adsl packet-mark=STD-PKT parent=\
    upload-adsl queue=default
add max-limit=1M name=upload-std-sdsl packet-mark=STD-PKT parent=upload-sdsl \
    queue=default
/snmp community
set [ find default=yes ] name=serveurcom write-access=yes
/interface bridge port
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=sfp1
add bridge=bridge comment=defconf interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=LAN_DATA interface=bridge list=LAN
add comment=LAN_VOIP interface=ether3 list=LAN
add comment=WAN_ADSL interface=adsl-ether1 list=WAN
add comment=WAN_SDSL interface=ether2 list=WAN
/ip address
add address=192.168.250.254/24 comment=LAN_VOIP interface=ether3 network=\
    192.168.250.0
add address=192.168.1.1/24 comment=LAN_DATA interface=bridge network=\
    192.168.1.0
add address=88.218.15.218/30 comment=WAN_SDSL interface=ether2 network=\
    88.218.15.216
/ip dhcp-server lease
add address=192.168.250.250 mac-address=D8:DF:0D:00:64:D6 server=\
    lan_voip_dhcp
/ip dhcp-server network
add address=192.168.1.0/24 comment=LAN_DATA dns-server=192.168.1.1 gateway=\
    192.168.1.1
add address=192.168.250.0/24 comment=LAN_VOIP dns-server=8.8.8.8,8.8.4.4 \
    gateway=192.168.250.254
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,1.1.1.1,8.8.4.4
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="accept 8080" dst-port=8080 \
    in-interface-list=WAN protocol=tcp
add action=accept chain=input comment="Accept SNMP from Serveurcom" dst-port=\
    161,162 in-interface-list=WAN protocol=udp src-address=85.14.167.193
add action=accept chain=input dst-port=161,162 in-interface-list=WAN \
    protocol=udp src-address=85.14.167.234
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall mangle
add action=mark-connection chain=prerouting comment="Mark SIP connections" \
    dst-port=5060 in-interface=ether3 new-connection-mark=VOIP-CONN \
    passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="Mark RTP connections" \
    in-interface=ether3 new-connection-mark=VOIP-CONN passthrough=yes \
    protocol=udp src-port=6000-7000
add action=mark-packet chain=prerouting comment="Mark VOIP packets" \
    connection-mark=VOIP-CONN in-interface=ether3 new-packet-mark=VOIP-PKT \
    passthrough=yes
add action=change-dscp chain=prerouting comment=\
    "Change DSCP to 46 for VOIP connections" connection-mark=VOIP-CONN \
    in-interface=ether3 new-dscp=46 passthrough=yes
add action=mark-connection chain=prerouting comment=\
    "Mark standard connections" connection-mark=no-mark in-interface-list=LAN \
    new-connection-mark=STD-CONN passthrough=yes
add action=mark-packet chain=prerouting comment="Mark standard packets" \
    connection-mark=STD-CONN in-interface-list=LAN new-packet-mark=STD-PKT \
    passthrough=yes
add action=mark-routing chain=prerouting comment=\
    "Route standard connections to ADSL" connection-mark=STD-CONN \
    in-interface-list=LAN new-routing-mark=to_ADSL passthrough=yes
add action=mark-routing chain=prerouting comment=\
    "Route VOIP connections to SDSL" connection-mark=VOIP-CONN \
    in-interface-list=LAN new-routing-mark=to_SDSL passthrough=yes
add action=mark-connection chain=prerouting comment=\
    "Route connections initiated from ADSL to ADSL" connection-mark=no-mark \
    in-interface=adsl-ether1 new-connection-mark=STD-CONN-ADSL passthrough=\
    yes
add action=mark-routing chain=prerouting connection-mark=STD-CONN-ADSL \
    in-interface-list=LAN new-routing-mark=to_ADSL passthrough=yes
add action=mark-connection chain=input connection-mark=no-mark in-interface=\
    adsl-ether1 new-connection-mark=STD-CONN-ADSL passthrough=yes
add action=mark-routing chain=output connection-mark=STD-CONN-ADSL \
    new-routing-mark=to_ADSL passthrough=yes
add action=mark-connection chain=prerouting comment=\
    "Route connections initiated from SDSL to SDSL" connection-mark=no-mark \
    in-interface=ether2 new-connection-mark=STD-CONN-SDSL passthrough=yes
add action=mark-routing chain=prerouting connection-mark=STD-CONN-SDSL \
    in-interface-list=LAN new-routing-mark=to_SDSL passthrough=yes
add action=mark-connection chain=input connection-mark=no-mark in-interface=\
    ether2 new-connection-mark=STD-CONN-SDSL passthrough=yes
add action=mark-routing chain=output connection-mark=STD-CONN-SDSL \
    new-routing-mark=to_SDSL passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat comment=BERONET dst-port=8181 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.250.250 to-ports=\
    80
/ip firewall service-port
set sip disabled=yes
/ip route
add check-gateway=ping distance=1 gateway=adsl-ether1 routing-mark=to_ADSL
add check-gateway=ping distance=1 gateway=88.218.15.217 routing-mark=to_SDSL
add check-gateway=ping distance=2 gateway=adsl-ether1 routing-mark=to_SDSL
add check-gateway=ping distance=1 gateway=adsl-ether1
/ip service
set www port=8080
/lcd interface pages
set 0 interfaces=wlan1
/snmp
set enabled=yes
/system clock
set time-zone-name=Europe/Paris
/system ntp client
set enabled=yes server-dns-names=fr.pool.ntp.org
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Thanks,

Joris

Who is online

Users browsing this forum: Bing [Bot] and 47 guests