Community discussions

 
LevanM
just joined
Topic Author
Posts: 1
Joined: Sat Jul 20, 2019 3:42 pm

Mikrotik / Asterisk - Problem with incoming call

Sat Jul 20, 2019 5:56 pm

Hello

I have successfully installed Asterisk. Made SIP configuration and the status is Registered

But when I'm trying to reach my phone number from mobile, it says that number is not registered.

I have Mikrotik router with ip firewall rulse
/ip firewall filter
add action=accept chain=input dst-port=1194 in-interface=ether7 protocol=tcp
add action=fasttrack-connection chain=forward comment=FastTrack connection-state=established,related
add action=accept chain=forward comment="Established, Related" connection-state=established,related
add action=accept chain=input comment="default configuration" connection-state=established,related
add action=accept chain=input log=yes log-prefix="Allowed List - " src-address-list=allowed_to_router
add action=accept chain=input protocol=icmp
add action=drop chain=input
add action=drop chain=forward comment="Drop tries to reach not public addresses from LAN" dst-address-list=not_in_internet in-interface=ether7 log=yes \
    log-prefix=!public_from_LAN out-interface=!ether7
add action=drop chain=forward comment="Drop incoming packets that are not NATted" connection-nat-state=!dstnat connection-state=new in-interface=ether7 log=yes \
    log-prefix=!NAT
add action=drop chain=forward comment="Drop incoming from internet which is not public IP" in-interface=ether7 log=yes log-prefix=!public src-address-list=\
    not_in_internet
add action=drop chain=forward comment="Drop packets from LAN that do not have LAN IP" in-interface=ether7 log=yes log-prefix=LAN_!LAN src-address=!10.38.9.0/24
add action=drop chain=forward comment="Drop invalid" connection-state=invalid log=yes log-prefix=invalid
# jul/20/2019 18:50:47 by RouterOS 6.45.1
# software id = 25JQ-8AIM
#
# model = RouterBOARD 3011UiAS
# serial number = 8EED096C668D
/ip firewall nat
add action=masquerade chain=srcnat
add action=dst-nat chain=dstnat dst-address=178.145.158.210 dst-port=5060 log=yes log-prefix="asterisk (dst-nat) - " protocol=udp to-addresses=10.38.9.20 \
    to-ports=5060

Who is online

Users browsing this forum: Bing [Bot] and 51 guests