Community discussions

MikroTik App
 
ab130kd
newbie
Topic Author
Posts: 32
Joined: Thu Mar 02, 2006 8:11 pm
Location: Italy

Mac telnet problem after upgrade... wrong password

Wed Jul 24, 2019 12:31 pm

after Upgrade, if i try to enter on a CPE mikrotik via mac-telnet the response is always:
"Login failed, incorrect username or password

Connection closed"

If i use IP, first time tell wrong password, second time I can enter.
The problem occured after upgrade 6.45.xx .
I try with winbox 3.19 but no solution..

Anybody has solution?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6111
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Mac telnet problem after upgrade... wrong password

Wed Jul 24, 2019 12:35 pm

Mac telnet will not work if you try to telnet to device with installed older RouterOS (with old user store)
 
vohr56
just joined
Posts: 3
Joined: Mon Jul 15, 2019 4:51 pm

Re: Mac telnet problem after upgrade... wrong password

Fri Aug 09, 2019 2:15 pm

Same problem here. RB750 Gr3 with 6.45.3 (Stable) installed and bootloader upgraded too. After upgrade, I reseted RB750 to defaults with "No Default Configuration" and "Do Not Backup" option marked and after reset I've lost access by mac-telnet from a CCR-1009 with v.6.42.6 that is connected directly to RB750. Same error that user ab130kd has:

Login failed, incorrect username or password

Connection closed

It´s a bug on newer ROS versions, which did not happen on older versions.

Access from a PC with Winbox v3.19 by mac works normally.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6111
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Mac telnet problem after upgrade... wrong password

Fri Aug 09, 2019 5:20 pm

see my post above.
You will not be able to connect from old ROS versions to 6.45.3
 
vohr56
just joined
Posts: 3
Joined: Mon Jul 15, 2019 4:51 pm

Re: Mac telnet problem after upgrade... wrong password

Wed Aug 14, 2019 2:31 pm

Haaaaa, I don't believe! Is this informed in some changelog? I didn't see.

I think that this is bad, because is very difficult to maintain all MK in field updated. So, when some problem happens, very very problably mac-telnet will not work because probably MKs will have different ROS versions. Come on man! Bad, very bad...
 
georgehoppper11
just joined
Posts: 2
Joined: Mon Nov 11, 2013 3:07 pm

Re: Mac telnet problem after upgrade... wrong password

Sun Oct 20, 2019 7:11 am

I would like to also add my vote that is a not very nice surprise. As vohr56 noted, it is very difficult to maintain all MTs in the field at the same OS. MikroTik -please fix this issue.
 
mkx
Forum Guru
Forum Guru
Posts: 4634
Joined: Thu Mar 03, 2016 10:23 pm

Re: Mac telnet problem after upgrade... wrong password

Sun Oct 20, 2019 11:19 am

This behaviour is not a bug, it's a security feature which has to do with the way passwords are stored on ROS devices ... we'll just have to live with it.
BR,
Metod
 
Zacharias
Forum Guru
Forum Guru
Posts: 2309
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Mac telnet problem after upgrade... wrong password

Sun Oct 20, 2019 12:26 pm

Haaaaa, I don't believe! Is this informed in some changelog? I didn't see.

I think that this is bad, because is very difficult to maintain all MK in field updated. So, when some problem happens, very very problably mac-telnet will not work because probably MKs will have different ROS versions. Come on man! Bad, very bad...
Its an improvement... not something bad...
6.43 changelog:
*) user - all passwords are now hashed and encrypted, plaintext passwords are kept for downgrade (will be removed in later upgrades)
https://mikrotik.com/download/changelogs/

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot], nichky, sindy and 69 guests