Community discussions

MikroTik App
 
WojtusW5
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 94
Joined: Mon Oct 02, 2017 1:25 pm

Queuing bandwidth test

Wed Jul 31, 2019 3:20 pm

Hi, I am trying to perform a configuration that will prioritize LAN traffic and limit BT made from the RouterOS level. I assumed that I would use a queue tree with this priority setting. Unfortunately, this solution does not work (BT has a higher speed than LAN).
/interface bridge
add name=br_lan protocol-mode=none
/queue tree
add name=tree1 packet-mark=no-mark parent=ether1
add name=queue2 packet-mark=poi parent=tree1 priority=3
add name=queue1 packet-mark=qwe parent=tree1 priority=5
/interface bridge port
add bridge=br_lan hw=no interface=ether2
/ip address
add address=192.168.210.1/24 interface=br_lan network=192.168.210.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/ip firewall mangle
add action=mark-packet chain=prerouting new-packet-mark=poi passthrough=no src-address=192.168.210.0/24
add action=mark-packet chain=postrouting dst-address=192.168.210.0/24 new-packet-mark=poi passthrough=no
add action=mark-packet chain=output dst-address=178.216.40.124 new-packet-mark=qwe passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
What am I doing wrong ?
Thank you in advance for your help.
 
User avatar
Steveocee
Forum Guru
Forum Guru
Posts: 1120
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: Queuing bandwidth test  [SOLVED]

Thu Aug 01, 2019 1:30 pm

For a queue priority to work the tree needs to know it is getting to it's maximum. As you haven't set a max-limit then the tree won't ever prioritise one sub-tree (branch) over another.

Set a reasonable max-limit on "tree1" and it should start working.
 
WojtusW5
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 94
Joined: Mon Oct 02, 2017 1:25 pm

Re: Queuing bandwidth test

Sat Aug 03, 2019 12:35 pm

Right, stupid mistake :(
Thank you for your help
/queue tree
add max-limit=20M name=master_up parent=ether1 queue=pcq-upload-default
add max-limit=200M name=master_down parent=global queue=pcq-download-default
add limit-at=1M max-limit=200M name=lan_down packet-mark=lan_down parent=master_down priority=7 queue=pcq-download-default
add limit-at=500k max-limit=200M name=epix_down packet-mark=epix_down parent=master_down queue=pcq-download-default
add limit-at=1M max-limit=20M name=lan packet-mark=lan_up parent=master_up priority=7 queue=pcq-upload-default
add limit-at=500k max-limit=20M name=epix packet-mark=epix_up parent=master_up queue=pcq-upload-default

Who is online

Users browsing this forum: alixviral, foresthus, Google [Bot], maldridge and 51 guests