Community discussions

 
gergoslsm
just joined
Topic Author
Posts: 6
Joined: Mon Jan 26, 2015 7:59 pm

PPTP public ip routage

Tue Aug 13, 2019 7:17 pm

Hello,

I am trying to give a public ip to a VPN client. But impossible to see this one from the web .
My config :
WAN : ether2 87.X.X.45/32
VPN : 213.X.X.80/28
PPP server detail : name="moi" service=any caller-id="" password="XXXX" profile=default local-address=213.X.X.81 remote-address=213.X.X.82 routes="" limit-bytes-in=0 limit-bytes-out=0

213.X.X.81 is OK on the web :
--- 213.X.X.81 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 4.686/4.756/4.839/0.101 ms

213.X.X.81 is NOK on the web :
--- 213.X.X.82 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2007ms

If you have an idea
 
sindy
Forum Guru
Forum Guru
Posts: 3774
Joined: Mon Dec 04, 2017 9:19 pm

Re: PPTP public ip routage

Tue Aug 13, 2019 10:05 pm

Post the configuration. Does the 213.x.x.x/28 have any external gateway to access the internet or is only accessible from outside via the 87.x.x.x?
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
gergoslsm
just joined
Topic Author
Posts: 6
Joined: Mon Jan 26, 2015 7:59 pm

Re: PPTP public ip routage

Tue Aug 13, 2019 10:39 pm

Hello,

/interface ethernet
set [ find default-name=ether1 ] name=ether2
set [ find default-name=ether2 ] name=ether3
/ip pool
add name=pptp ranges=213.X.X.81-213.X.X.83
/ppp profile
add dns-server=8.8.8.8 local-address=213.X.X.80 name=profile1-ppp \
remote-address=pptp
/tool user-manager customer
set admin access=\
own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface l2tp-server server
set enabled=yes
/interface pptp-server server
set authentication=chap default-profile=profile1-ppp enabled=yes max-mru=1460 \
max-mtu=1460
/ip address
add address=87.X.X.45 interface=ether2 network=87.X.X.45
add address=87.X.X.45 interface=ether2 network=164.X.X.254
add address=213.X.X.80 disabled=yes interface=ether3 network=\
164.X.X.254
add address=213.X.X.80/28 disabled=yes interface=ether3 network=\
213.X.X.80
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether2
add action=masquerade chain=srcnat out-interface=ether3
/ip route
add distance=1 gateway=164.X.X.254
/ppp secret
add local-address=213.X.X.81 name=moi password=pass remote-address=\
213.X.X.82

Who is online

Users browsing this forum: Bing [Bot] and 77 guests