Community discussions

 
ShyLion
newbie
Topic Author
Posts: 27
Joined: Thu Sep 28, 2017 7:24 am

Disable local echo

Wed Aug 14, 2019 4:12 pm

Hello.
Is there any way to disable local echo on ssh console?
Local echo is then you type something, it prints it back, so your terminal program see that. Makes scripting a pain.
 
Cendig
just joined
Posts: 2
Joined: Wed Aug 14, 2019 1:42 am

Re: Disable local echo

Wed Aug 14, 2019 4:48 pm

Just tested this on a spare hAP Lite ( 6.40.8 ) I have and this does not seem to be default behaviour.
Sounds more like what happens when you use Telnet with command echo turned on...
Also, are you accessing the device with the ssh -t command?
 
ShyLion
newbie
Topic Author
Posts: 27
Joined: Thu Sep 28, 2017 7:24 am

Re: Disable local echo

Thu Aug 15, 2019 8:04 am

I'm accessing device using libssh2 library from my programm and i clearly see that devices echoes everything entered back. And that's normal behavior for interactive sessions.
 
Cendig
just joined
Posts: 2
Joined: Wed Aug 14, 2019 1:42 am

Re: Disable local echo

Fri Aug 16, 2019 2:48 pm

I'm accessing device using libssh2 library from my programm and i clearly see that devices echoes everything entered back. And that's normal behavior for interactive sessions.
Ah sorry, didn't realise that you were accessing it this way, not sure how to stop that.

Who is online

Users browsing this forum: No registered users and 53 guests