Page 1 of 1

Problem accessing Winbox via Mac address

Posted: Fri Aug 23, 2019 5:29 pm
by adilsemedo
Recetly I´ve facing a problem accessing the mikrotik devices through mac address:
i can´t do nothing, as soon as i try to connect to DISC LITE, 2 or 3 seconds it gives me this message:
"router XX:XX:XX:XX:XX:XX has been disconnected min go"

I´m using Winbox 3.19
Device: DiscLite AC (arm)


This problems was found recently. In the past i usualy erase all the "default conf" and through mac address made all configuration.


solution found till now.
When i access the device for the first time, without erase the "default configuration" i put one IP address at the eth interface in order to configure it.

any ideia what´s going on?

Re: Problem accessing Winbox via Mac address

Posted: Sat Aug 24, 2019 6:44 pm
by krafg
Make sure that your psysical Ethernet interface is the only that is enabled.

Regards.

Re: Problem accessing Winbox via Mac address

Posted: Mon Aug 26, 2019 2:52 pm
by adilsemedo
Make sure that your psysical Ethernet interface is the only that is enabled.

Regards.
Hello,

tks Krafg,
but even with only the ethernet interface i´m no able to access it.

Re: Problem accessing Winbox via Mac address

Posted: Mon Aug 26, 2019 3:25 pm
by SiB
My problems with Layer2 connectivity to WinBox was with:
[*] AntyVirus IPS/Firewall protection on my Laptop
[*] When I disable all other interfaces like Wifi, Bluetooth, Virtual Ethernet from PCAP or GNS3 etc.
[*] Disable not used protocols at Network interface Property

Those stuff help me with MAC connectivity and always are about my PC.
I hope you found your and fix it.

My workaround are always have with me a one MikroTik and connect via Mac telnet from him as bypass or RoMon connection.

Re: Problem accessing Winbox via Mac address

Posted: Mon Aug 26, 2019 4:10 pm
by adilsemedo
Tks for your rply #SiB,

it appears a good solution. But i like to use the Winbox app.
it´s very odd because in times i could access the devices normally. Now i dont know yet what really happened.
I watched all software installed the last days but didnt find nothing yet.

Re: Problem accessing Winbox via Mac address

Posted: Mon Aug 26, 2019 5:11 pm
by SiB
Your RB have one Ethernet interface (and wireless too) then you must be sure to have it in
/tool mac-server mac-winbox set allowed-interface-list=all;
# OR remember to add ether1 to mac-winbox
/interface list member set list=mac-winbox interface=ether1;
# OR use IP connectivity
I don't know how works "Default configuration" at one ethernet device but common is to block WinBox MAC at ether1 as WAN port.
PS. You can always run WireShark at your PC and check if you receive any MikroTik Neighbor Discovery protocol (MNDP) at UDP: 5678