Community discussions

 
elovo
just joined
Topic Author
Posts: 1
Joined: Fri Aug 30, 2019 1:52 pm

Changed Hotspot login to HTTPS and get "login failed: invalid username or password"

Fri Aug 30, 2019 4:19 pm

Hello Everyone.

I have a Mikrotik x86 6.44.5(long-term) running on a VM to host as a Hotspot.
It worked ok, but needed to add a Certificate.
After the Certificate was added and changed login to HTTPS, the users often get "login failed: invalid username or password", after 3-5 tries, it accepts.
I am using a Radius Server.
If i go back to HTTP - PAP, there is no issues.
Does anyone have any tips on what might be the issue ?

After adding the Certificate, i also had an issue with High CPU usage, which made me add the following firewall rules which was mentioned here: viewtopic.php?t=125201

/ip firewall filter
add action=accept chain=pre-hs-input comment="Limit https unauth " \
connection-state=new disabled=no dst-limit=1,1,src-address/1m40s dst-port=\
64875 protocol=tcp

add action=reject chain=pre-hs-input connection-state=new disabled=no dst-port=\
64875 protocol=tcp reject-with=icmp-admin-prohibited

add action=accept chain=pre-hs-input comment="limit http unauth" \
connection-state=new disabled=no dst-limit=1,1,src-address/1m40s dst-port=\
64874 protocol=tcp

add action=reject chain=pre-hs-input connection-state=new disabled=no dst-port=\
64874 protocol=tcp reject-with=icmp-admin-prohibited

Could these effectively create my issue?
I haven't tested by removing these, as it makes the portal not working due to the amount of HTTPS requests spikes the CPU.

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 42 guests