Community discussions

 
nemke
Member Candidate
Member Candidate
Topic Author
Posts: 107
Joined: Thu Jul 31, 2014 2:52 am

DHCP CAPSMAN Problem

Sun Sep 01, 2019 10:14 pm

Hello
Strange thing. Did I miss something. I export only setup for this

/interface vlan
add interface=bridge254 name=b-vlan254 vlan-id=254
add comment=Gosti interface=sfp-sfpplus1 name=vlan254 vlan-id=254
/interface bridge port
add bridge=bridge254 interface=b-vlan254
add bridge=bridge254 interface=vlan254
/ip address
add address=192.168.254.1/24 interface=bridge254 network=192.168.254.0
/ip dhcp-server
add address-pool=Gosti disabled=no interface=bridge254 lease-time=1d name=Gosti
/ip dhcp-server network
add address=192.168.254.0/24 dns-server=212.200.191.166,212.200.190.166 gateway=192.168.254.1
/ip pool
add name=Gosti ranges=192.168.254.2-192.168.254.254
/caps-man channel
add band=2ghz-b/g/n control-channel-width=20mhz name="Channel auto 2"
add band=5ghz-a/n/ac control-channel-width=20mhz name="Channel Auto 5"
/caps-man datapath
add bridge=bridge88 client-to-client-forwarding=yes local-forwarding=yes name=petrovic
add bridge=bridge254 name=gosti vlan-id=254 vlan-mode=use-tag
add bridge=bridge89 client-to-client-forwarding=yes name=ponjavic vlan-id=89 vlan-mode=use-tag
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm name=Petrovic passphrase=shinoamurabe
add authentication-types=wpa2-psk encryption=aes-ccm name=Gost passphrase=freespot
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm name=Ponjavic passphrase=ponjavic1234
/caps-man configuration
add channel="Channel auto 2" country=serbia datapath=petrovic mode=ap name="AP Stan" rates.vht-basic-mcs="" rates.vht-supported-mcs="" security=Petrovic ssid="Wi-Fi Stan"
add channel="Channel auto 2" country=serbia datapath=gosti mode=ap name=Gost security=Gost ssid=Gost
add channel="Channel Auto 5" country=serbia datapath=petrovic mode=ap name="Stan Petrovic 5GHz" rates.vht-basic-mcs="" rates.vht-supported-mcs="" security=Petrovic ssid="Wi-Fi Stan 5GHz"
add channel="Channel Auto 5" country=serbia datapath=ponjavic mode=ap name="Stan Ponjavic 5GHz" security=Ponjavic ssid="Ponjavic Wi-Fi 5GHz"
/caps-man access-list
add action=accept allow-signal-out-of-range=10s disabled=no interface=all signal-range=-80..120 ssid-regexp=""
add action=reject allow-signal-out-of-range=10s disabled=no interface=all signal-range=-120..-81 ssid-regexp=""
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes
/caps-man manager interface
add disabled=no interface=bridge88
add disabled=no interface=bridge89
add disabled=no interface=bridge999
/caps-man provisioning
add action=create-dynamic-enabled comment="AP Prizemlje" master-configuration=Gost name-format=identity radio-mac=CC:2D:E0:AF:A7:E6
add action=create-dynamic-enabled comment="AP Prizemlje" master-configuration="Stan Petrovic 5GHz" name-format=identity radio-mac=CC:2D:E0:AF:A7:E7 slave-configurations="Stan Ponjavic 5GHz"
add action=create-dynamic-enabled comment="AP Sprat" master-configuration=Gost name-format=identity radio-mac=CC:2D:E0:E7:87:EE
add action=create-dynamic-enabled comment="AP Sprat" master-configuration="Stan Petrovic 5GHz" name-format=identity radio-mac=CC:2D:E0:E7:87:ED
add action=create-dynamic-enabled comment="AP Podrum" master-configuration=Gost name-format=identity radio-mac=B8:69:F4:F0:C2:FB
add action=create-dynamic-enabled comment="AP Podrum" master-configuration="Stan Petrovic 5GHz" name-format=identity radio-mac=B8:69:F4:F0:C2:FC
add action=create-dynamic-enabled comment="AP Terasa" master-configuration="AP Stan" name-format=identity radio-mac=E4:8D:8C:4D:63:20 slave-configurations=Gost

In this setup DHCP DON't assigned ANY IP to clieint (on SSID Gosti), so connection to SSID is TIME OUT.
If I change this param:

/ip address
add address=192.168.254.1/24 interface=b-vlan254 network=192.168.254.0
/ip dhcp-server
add address-pool=Gosti disabled=no interface=b-vlan254 lease-time=1d name=Gosti
/ip dhcp-server network
add address=192.168.254.0/24 dns-server=212.200.191.166,212.200.190.166 gateway=192.168.254.1
all work fine, DHCP gice IP address to wirelss clients.

WHY ?
How I know, IP address and DHCP need to be on BRIDGE not on Vlan (of vlan is in bridge)

Who is online

Users browsing this forum: Google [Bot] and 44 guests