Community discussions

 
BatavianX
just joined
Topic Author
Posts: 2
Joined: Thu Aug 14, 2008 5:23 am

Low Throughput on 2011  [SOLVED]

Wed Sep 04, 2019 4:30 am

2011UiAS-2HnD
ROS 6.45.5
With minimal config, I only managed to max out at 100mbps, CPU at 100%, when I connect a laptop to my modems, I can get 300mbps++ easily.

Image
# sep/04/2019 08:20:53 by RouterOS 6.45.5
# software id = 08MN-462Z
#
# model = 2011UiAS-2HnD
# serial number = 5694047FFB97
/interface ethernet
set [ find default-name=ether1 ] name=ether1.indihome
set [ find default-name=ether2 ] name=ether2.oxygen
set [ find default-name=ether5 ] name=ether5.x-region
set [ find default-name=ether10 ] disabled=yes
/interface pppoe-client
add ac-name=BRAS3-D2-JT add-default-route=yes disabled=no interface=ether1.indihome name=indihome password=XXXXXXXXX service-name=\
    INTERNET user=XXXXXXXXXX@apps.xxxxxx
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=x-region.net_fo_TFO-10036
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=allowed mode=dynamic-keys name=wpa2-psk \
    supplicant-identity="" wpa-pre-shared-key=kambinguling wpa2-pre-shared-key=kambinguling
/interface wireless
set [ find default-name=wlan1 ] arp=reply-only band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto \
    hide-ssid=yes installation=indoor mode=ap-bridge name=wlan01 security-profile=wpa2-psk ssid=SiMeongAnakCantik wireless-protocol=\
    802.11
/ip pool
add name=wifi ranges=192.168.69.0/24
/ip dhcp-server
add add-arp=yes address-pool=wifi authoritative=after-2sec-delay disabled=no interface=wlan01 lease-time=30m name=wifi
/ip neighbor discovery-settings
set discover-interface-list=all
/ip settings
set allow-fast-path=no
/interface list member
add interface=indihome list=WAN
add interface=ether2.oxygen list=WAN
add interface=ether5.x-region list=LAN
add interface=wlan01 list=LAN
/ip address
add address=192.168.200.2/24 comment=defconf interface=ether1.indihome network=192.168.200.0
add address=192.168.88.88/24 interface=ether5.x-region network=192.168.88.0
add address=192.168.69.2/24 interface=wlan01 network=192.168.69.0
/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=ether2.oxygen use-peer-dns=no use-peer-ntp=no
/ip dhcp-server network
add address=192.168.69.0/24 dns-server=8.8.8.8 gateway=192.168.69.2 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" disabled=yes protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new \
    in-interface-list=WAN
/ip firewall mangle
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=oxygen passthrough=no src-address=192.168.88.200
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/ip route
add distance=1 gateway=192.168.1.1 routing-mark=oxygen
add distance=1 gateway=indihome
add distance=2 gateway=192.168.1.1
Last edited by BatavianX on Sun Sep 08, 2019 6:05 am, edited 1 time in total.
 
mkx
Forum Guru
Forum Guru
Posts: 3183
Joined: Thu Mar 03, 2016 10:23 pm

Re: Low Throughput on 2011

Wed Sep 04, 2019 8:23 am

Any good reason for this setting:

/ip settings
set allow-fast-path=no

I believe it might kill the RB's performance.

Anyway, there might be two reasons for limit:
  1. ports eth6-eth10 are 100Mbps only
  2. run CPU profile while hammering RB with traffic to see if CPU is bottleneck (and which process is consuming CPU cycles)
BR,
Metod
 
BatavianX
just joined
Topic Author
Posts: 2
Joined: Thu Aug 14, 2008 5:23 am

Re: Low Throughput on 2011

Wed Sep 04, 2019 9:05 am

I dont know why if
/ip settings set allow-fast-path=yes
I can't open any website at all, ping is good though, I can't even press reply to your post until I disabled it.
I only using port 1 and 5 in the RB.
At one point I disable all the rule and queues leaving only 1 NAT - 1 mangle and 1 route, basically the only rule you need to connect, but still I only manage to max the RB to 120mbps, at this point I can only presume that I got a bad unit, thinking going to x86.

Thanks for your reply.
 
mkx
Forum Guru
Forum Guru
Posts: 3183
Joined: Thu Mar 03, 2016 10:23 pm

Re: Low Throughput on 2011

Wed Sep 04, 2019 9:15 am

I can only guess (perhaps some other forum guru will come to rescue) ... you have mangle rule which doesn't work if packets, which have to be mangled, are fast-tracked. So disabling fast-path in your case actually causes fast-track to be disabled, making mangle rule working. The proper way of doing it, though, would be to adjust fast-track rule so that it will skip the packets which need to be mangled ...
BR,
Metod
 
pe1chl
Forum Guru
Forum Guru
Posts: 5920
Joined: Mon Jun 08, 2015 12:09 pm

Re: Low Throughput on 2011

Wed Sep 04, 2019 12:23 pm

At one point I disable all the rule and queues leaving only 1 NAT - 1 mangle and 1 route, basically the only rule you need to connect, but still I only manage to max the RB to 120mbps, at this point I can only presume that I got a bad unit, thinking going to x86.
A limited performance is likely not caused by "a bad unit".
You should consider that the 2011 is an old device and typical 100 Mbps operation is about what you can expect from it.
Sure there are tricks like fast-path and fast-track to boost performance but they cut into the functionality. You apparently require some of that functionality so you cannot use that.
I have my 2011 connected to a 100 Mbps line and I can see that when I fully load it, the CPU load is considerable.
So I am not surprised that you hit some limit, although I would have expected it to be a little higher.

There are much faster routers in the MikroTik product list today...
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1790
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Low Throughput on 2011

Wed Sep 04, 2019 1:06 pm

Hey

* with fast-path disabled, fast-track will not work either
* you'll need to exclude 88.200 from fasttrack, or manling for route mark will not work

* You seem to have two wans? indihome + oxygen
is oxygen some vpn for 88.200 only?

* you have in config
/interface pppoe-client
add ac-name=BRAS3-D2-JT add-default-route=yes interface=ether1.indihome name=indihome

/ip route
add distance=1 gateway=indihome

shouldn't the add-default-route be disabled as the route is already configured manually?

* with fast-path / fast-track enabled 2011 is capable of 300+mbps traffic

edit: some typos

Who is online

Users browsing this forum: MSN [Bot] and 90 guests