Community discussions

 
stretters
just joined
Topic Author
Posts: 1
Joined: Tue Sep 10, 2019 1:57 pm

In interface out same interface not working

Tue Sep 10, 2019 2:28 pm

Hey Guys,

We have a bunch of Mikrotiks set up as SOHO routers.

A lot of which have 2 DSLs using PPPoE. We use mangle rules to ensure the traffic that comes in on one interface goes out the same. This worked perfectly but has stopped working on latest software on some Routers but not all.. Basically I can ping the primary but not the secondary and both are up all firewall rules are set to in-interface=all-ppp so if one works both should.

Here is the relevant part of my config hopefully someone can suggest why this isn't working

This router is a 951Ui-2HnD on up to date firmware / Ros 6.45.3. The remote address given by the PPPoE client is different on the pppoe interfaces

/interface pppoe-client
add disabled=no interface=ether1 keepalive-timeout=60 name=pppoe-pri password=\
redacted user=redacted
add disabled=no interface=ether2 keepalive-timeout=60 name=pppoe-sec password=\
redacted user=redacted
/ip firewall mangle
add action=mark-connection chain=prerouting comment="Primary Routing" in-interface=pppoe-pri new-connection-mark=pppoe-pri passthrough=no
add action=mark-routing chain=prerouting connection-mark=pppoe-pri new-routing-mark=pppoe-pri passthrough=no
add action=mark-routing chain=output connection-mark=pppoe-pri new-routing-mark=pppoe-pri passthrough=no
add action=mark-connection chain=prerouting comment="Secondary Routing" in-interface=pppoe-sec new-connection-mark=pppoe-sec passthrough=no
add action=mark-routing chain=prerouting connection-mark=pppoe-sec new-routing-mark=pppoe-sec passthrough=no
add action=mark-routing chain=output connection-mark=pppoe-sec new-routing-mark=pppoe-sec passthrough=no
/ip route
add distance=1 gateway=pppoe-pri routing-mark=pppoe-pri
add distance=1 gateway=pppoe-sec routing-mark=pppoe-sec
add distance=1 gateway=pppoe-pri
add distance=2 gateway=pppoe-sec

Who is online

Users browsing this forum: No registered users and 49 guests