Page 1 of 1

disable root bridge

Posted: Wed Sep 11, 2019 9:29 am
by sebnx
Hello,

I use Mikrotik routers on our network in order to be able to do bandwidth tests (BTest).

If I connect the Mikrotik on a Netonix, the switch pass the port in "forwarding root" and the Mikrotik becomes Root Bridge ID...

To disable the root bridge I did the following action on the Mikrotik : Bridge > Ports select "Interface > all"
Bridge Port <all> and selected yes on Edge selector.

Is this the right method ??

Re: disable root bridge

Posted: Wed Sep 11, 2019 11:21 am
by mkx
"root bridge" is a feature of xSTP. If RB in question can not create any loops (e.g. it only has one connection to the rest of network), then you can disable xSTP entirely:
/interface bridge
set [ find protocol-mode!=none ] protocol-mode=none

Re: disable root bridge

Posted: Wed Sep 11, 2019 9:35 pm
by sebnx
The Mikrotik has only one port plugged into the Netonix switch. Other Mikrotik ports are disabled !

Thanks mkx for the command :)