Community discussions

 
hunters1094
just joined
Topic Author
Posts: 4
Joined: Thu Sep 12, 2019 5:11 am

Setup VPN for Mikrotik with PPPoE behind a modem in bridge mode

Thu Sep 12, 2019 5:30 am

Hi

I have a Mikrotik with RouterOS v6.43.5.

My topology is:

PCs ---------- Grandstream Wifi -------------- Mikrotik ----------- Modem ---------- ISP

Mikrotik has interface:
ether1: WAN
ether2: LAN (192.168.2.0/24 --> IP 192.168.2.1)

My modem is in bridge mode, and Mikrotik connects PPPoE to the ISP PPPoE server.

I configure VPN for my Mikrotik using PPTP Server.

Now I can connect to the internet normally and can connect to the VPN from inside LAN. I can telnet 192.168.2.1 1723 port.

But from internet, I can not ping or telnet 1273 port of IP WAN. I opened the firewall for port 1723 and ICMP.

[admin@MikroTik] > /ip firewall filter print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=input action=accept protocol=icmp log=no log-prefix=""

1 chain=input action=accept connection-state=established
connection-nat-state="" log=no log-prefix=""

2 chain=input action=accept connection-state=related log=no log-prefix=""

3 ;;; VPN Server
chain=input action=accept protocol=tcp dst-port=1723 log=no log-prefix=""

4 chain=input action=accept protocol=gre log=no log-prefix=""

5 chain=input action=drop in-interface=ether1 log=no log-prefix=""

What can I configure to connect VPN from the Internet?

Thank you.
 
hunters1094
just joined
Topic Author
Posts: 4
Joined: Thu Sep 12, 2019 5:11 am

Re: Setup VPN for Mikrotik with PPPoE behind a modem in bridge mode

Thu Sep 12, 2019 10:54 am

Hi.

This problem has been solved. Because the ISP provides my IP behind NAT. So I can not connect direct to it from internet.

Thank you.
 
hunters1094
just joined
Topic Author
Posts: 4
Joined: Thu Sep 12, 2019 5:11 am

Re: Setup VPN for Mikrotik with PPPoE behind a modem in bridge mode

Thu Sep 12, 2019 3:26 pm

Hi

My ISP Provider blocks the GRE network, so I change to user L2TP Server with IP Sec. And now, my client from internet can connect to the VPN and get VPN IP Address.

But the client can not connect (ping/telnet) to the Workstations inside VPN. It can only ping the gateway 192.168.2.1.

Please help me.

Thank you.
 
hunters1094
just joined
Topic Author
Posts: 4
Joined: Thu Sep 12, 2019 5:11 am

Re: Setup VPN for Mikrotik with PPPoE behind a modem in bridge mode

Thu Sep 12, 2019 6:20 pm

Hi

I've solved this problem. I use same same pool 192.168.2.0/24 for both VPN and LAN. So it is conflicted. I change to use different pools for them and it works now.

Thank you.

Who is online

Users browsing this forum: No registered users and 38 guests