Community discussions

 
ianngrh
just joined
Topic Author
Posts: 21
Joined: Thu Aug 30, 2018 6:53 am

Mac authentication Hotspot still popping up login page

Thu Sep 12, 2019 12:08 pm

Hi all,

I have a mikrotik that running multiple hotspot server and using mac address as username / password.
And my problem is I always get popup Sign in to network when I try to move to another hotspot server. It happened on android and iphone. As far as I know, when we use mac address as username & password, there would be no popup appeared, but I still get this

Image

And here is my configuration
/interface bridge
add name=loopback-hotspot
/interface vlan
add interface=ether3 name=vlan103 vlan-id=103
add interface=ether3 name=vlan104 vlan-id=104
/ip hotspot profile
add dns-name=myhotspot.com hotspot-address=172.16.255.1 login-by=mac,http-pap \
    mac-auth-mode=mac-as-username-and-password name=myhotspot
/ip hotspot user profile
set [ find default=yes ] shared-users=unlimited
add idle-timeout=1d !keepalive-timeout name=uprof1 session-timeout=1h \
    shared-users=unlimited

/ip pool
add name=pool-3 ranges=10.3.0.11-10.3.0.240
add name=pool-4 ranges=10.4.0.11-10.4.0.240
/ip dhcp-server
add address-pool=pool-3 conflict-detection=no disabled=no interface=ether3 \
    name=server-3 use-framed-as-classless=no
add address-pool=pool-4 conflict-detection=no disabled=no interface=ether4 \
    name=server-4 use-framed-as-classless=no
/ip hotspot
add address-pool=pool-3 addresses-per-mac=1 disabled=no interface=vlan103 \
    name=server3 profile=myhotspot
add address-pool=pool-4 disabled=no interface=vlan104 name=server4 profile=\
    myhotspot
		
/ip hotspot user
add name=38:A4:ED:B7:21:74 profile=uprof1
add name=2C:33:61:AC:76:60 profile=uprof1

/ip address
add address=192.168.1.71/24 interface=ether1 network=192.168.1.0
add address=192.168.24.1/24 interface=ether1 network=192.168.24.0
add address=10.3.0.1/24 interface=vlan103 network=10.3.0.0
add address=10.4.0.1/24 interface=vlan104 network=10.4.0.0
add address=172.16.255.1 interface=loopback-hotspot network=172.16.255.1

/ip dhcp-server network
add address=10.3.0.0/24 gateway=10.3.0.1
add address=10.4.0.0/24 gateway=10.4.0.1
/ip dns
set servers=8.8.8.8,1.1.1.1


/ip route
add distance=1 gateway=192.168.1.1

Sorry about my bad English, and thank you in advance
You do not have the required permissions to view the files attached to this post.
Still trying to be better than before

Who is online

Users browsing this forum: No registered users and 52 guests