Community discussions

 
hashmatfazly
just joined
Topic Author
Posts: 2
Joined: Mon Jul 02, 2018 8:55 am

how to allow pop3 from WAN1 and others from WAN 2

Mon Oct 07, 2019 1:33 pm

Hello everyone

i need some help to configure my MikroTik RB to use WAN1 for (POP3) outlook only and the rest of usage should be from WAN 2.
 
dmitris
newbie
Posts: 42
Joined: Mon Oct 09, 2017 1:08 pm

Re: how to allow pop3 from WAN1 and others from WAN 2

Mon Oct 07, 2019 2:30 pm

If you want reach mail server outside you organization, you can use src-nat for this...
/ip firewall nat
add action=masquerade chain=srcnat disabled=no dst-port=25,587,465,110,995 \
    out-interface=WAN1 protocol=tcp
add action=masquerade chain=srcnat disabled=no src-address=YOUR-SUBNET-HERE  \
    out-interface=WAN2
 
hashmatfazly
just joined
Topic Author
Posts: 2
Joined: Mon Jul 02, 2018 8:55 am

Re: how to allow pop3 from WAN1 and others from WAN 2

Mon Oct 07, 2019 7:00 pm

thanks worked only for outlook POP3 and SMTP. but for Microsoft exchange give error
 
dmitris
newbie
Posts: 42
Joined: Mon Oct 09, 2017 1:08 pm

Re: how to allow pop3 from WAN1 and others from WAN 2

Mon Oct 07, 2019 7:09 pm

try to add ...
dst-port=25,587,465,110,995,143,993
 
anav
Forum Guru
Forum Guru
Posts: 2971
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: how to allow pop3 from WAN1 and others from WAN 2

Mon Oct 07, 2019 7:59 pm

Hmm I did mine a little differently using IP routing.
WAN1 is primary (distance 2)
WAN2 is secondary (only used on failover) distance 10
However for all traffic with destination of IP address of email server,
(which smtp traffic resolves to via DNS) I have IP route rule that gives highest priority to secondary wan. distance 1

Not sure if that would be useful to you?
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)

Who is online

Users browsing this forum: No registered users and 77 guests