Community discussions

MUM Europe 2020
 
Znevna
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 70
Joined: Mon Sep 23, 2019 1:04 pm

[bug] WinBox/WebFig Wireless ACL - Signal Strength Range - input validation

Thu Nov 21, 2019 9:20 pm

Hello.
Bug present on 6.46beta59, might be present on stable, can't test right now, but maybe someone else can.
Later edit: bug was introduced in 6.46beta28, 6.46beta16 is fine, stable is fine.
There's some error with the default value for Signal Strength Range, and the validation for the values entered is wrong too.
Using WinBox, creating a new ACL defaults Signal Strength to "-1..120" which isn't quite usable, and it doesn't accept anything outside that range that can be usable.
winbox-wifi-acl.JPG
winbox-wifi-acl-err.JPG
Using WebFig, creating a new ACL defaults Signal Strength to "9223372032559809000..120" which again isn't usable, and the only value it accepts as input is either "-" or "-..-" which again, isn't usable in any way.
webfig-wifi-acl.JPG
From Terminal you can set whatever value you want though, in the -120..120 limits.
winbox-wifi-acl-input-from-terminal.JPG
You do not have the required permissions to view the files attached to this post.
 
Znevna
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 70
Joined: Mon Sep 23, 2019 1:04 pm

Re: [bug] WinBox/WebFig Wireless ACL - Signal Strength Range - input validation  [SOLVED]

Wed Nov 27, 2019 9:07 pm

Who is online

Users browsing this forum: ccardenas, erlinden, Google [Bot], inetwifinetwork, mrmut, mrz, w0lt, xt22 and 165 guests