Community discussions

MikroTik App
Cameron Earnshaw
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 91
Joined: Sun May 30, 2004 6:46 pm

Web Proxy Woes (Again)

Sat Dec 04, 2004 4:52 pm

After bad experiences with the MT web proxy in the past I had stayed away from using it, but recently I upgraded two routers to 2.8.19. so decided to try it again. It has been working flawlessly on both routers for over one month, but now one of the routers has developed the old problem where the pages won't load or load only partially. As soon as I delete the dst-nat rule that redirects to port 8080 (thereby bypassing the web proxy) everything starts working again. This router had just about reached the point where the hard drive was full, so I cleared the proxy thinking that was the problem. No change. I also tried reformatting the drive but the web proxy simply will not operate reliably on this machine any longer. This makes no sense, since it worked fine for over one month. I just don't trust this MT feature any longer. Am I the only one with this problem? Any ideas?
Member Candidate
Member Candidate
Posts: 122
Joined: Fri Jun 04, 2004 8:19 pm
Location: Ráckeve

Sat Dec 04, 2004 5:04 pm

we had this problem when we used a dsl line to behind the proxy. A bad choosen tcp mss could cause this problem to us. Now we have an other line, and no problem. - the country you must visit
User avatar
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany

Re: Web Proxy Woes (Again)

Sun Dec 05, 2004 10:59 am

upgraded two routers to 2.8.19. so decided to try it again....
Am I the only one with this problem? Any ideas?
same problem to me. i set the mss according to the mtu (1480) which works on the dsl-line. but no web-site is working through the proxy anymore. with 2.8.16 it has been working.

as far as i see the squid version has been updated. perhaps something has gone wrong there...

after reconfiguring the web-proxy (deleting old rules, etc.) everything is working now. here are my settings:
 ip web-proxy> export                                                                             
# dec/05/2004 21:41:26 by RouterOS 2.8.19
/ ip web-proxy 
set enabled=yes src-address= port=3128 hostname="proxy" transparent-proxy=yes parent-proxy= max-object-size="1024 kB" cache-drive=system max-cache-size=none 
/ ip web-proxy access 
add dst-port=!443,563 method=connect action=deny comment="allow CONNECT only to SSL ports 443 \[https\] and 563 \
    \[snews\]" disabled=no 
add src-address= action=allow comment="allow local hosts to use proxy" disabled=no 
add action=deny comment="default deny - must be last!" disabled=no 
/ ip web-proxy cache 
add url="cgi-bin \\?" action=deny comment="don't cache dynamic http pages" disabled=no 

/ip firewall dst-nat pr  

 0   ;;; transparenter http-proxy
     in-interface=lan dst-address=! protocol=tcp action=redirect to-dst-port=3128 

 1   in-interface=lan dst-address=! protocol=tcp action=redirect to-dst-port=3128 


Who is online

Users browsing this forum: anav, andlil, sindy, Zacharias and 70 guests