Page 1 of 1

PCQ Queue does not respect limits

Posted: Fri Dec 27, 2019 5:53 pm
by abernier
I am struggling with a setup I need to deploy. I am trying to replace the simple queues that the pppoe server creates for manual PCQ queues.
Below I put the configuration that I use, but I have realized that the speed of the clients is not limited as I thought, the 6Mbps clients have seen how they download at 12,18, ... 25Mbps. Fast path and Fast forward are disabled. Do I do something wrong?
Thank you in advance to anyone who is offering advice!

- Clients with pppoe server over a bridge
- a range of reserved IP at each speed (6 or 20 Mbps)
- Create PCQ Queue for two types of clients (6 and 20Mbps)

Not Working:
Clients with speed limitation: pcq queue with rate=6144k and burst-rate=7169k ; appear with downloads at higher speeds (14Mbps,.. 20Mbps,..)
While monitoring queues traffic shows on the avg rate column
/interface bridge
add fast-forward=no name=bridgeAT

/ip pool
add name=pool_Local ranges=
add name=pool_remote ranges=
add name=pppoe_06 ranges=
add name=pppoe_20 ranges=

/ppp profile
add dns-server=, local-address=pool_Local name=At remote-address=pool_remote
add change-tcp-mss=yes dns-server=, name=PPPoE_20Mbps/4Mbps only-one=yes rate-limit="" remote-address=pppoe_20
add change-tcp-mss=yes dns-server=, name=PPPoE_06Mbps/1Mbps only-one=yes rate-limit="" remote-address=pppoe_06

/queue type
add kind=pcq name=06M-pcq-download pcq-burst-rate=7169k pcq-burst-threshold=16 pcq-burst-time=16s pcq-classifier=dst-address pcq-rate=6144k pcq-total-limit=4200KiB
add kind=pcq name=20M-pcq-download pcq-burst-rate=21504k pcq-burst-threshold=16 pcq-burst-time=16s pcq-classifier=dst-address pcq-rate=20480k pcq-total-limit=3200KiB

/queue tree
add max-limit=60M name=Q_AT parent=bridgeAT
add name=q_06 packet-mark=Down_06 parent=Q_AT queue=06M-pcq-download
add name=q_20 packet-mark=Down_20 parent=Q_AT queue=20M-pcq-download

/interface bridge port
add bridge=bridgeAT horizon=10 hw=no interface=ether1
add bridge=bridgeAT horizon=10 hw=no interface=ether2
add bridge=bridgeAT horizon=10 hw=no interface=ether3

/interface bridge settings
set allow-fast-path=no
/ip firewall connection tracking
set enabled=yes tcp-established-timeout=1h
/ip settings
set allow-fast-path=no

/ip firewall mangle
add action=mark-connection chain=forward connection-state=new new-connection-mark=C-Down_06 passthrough=yes src-address=
add action=mark-packet chain=forward connection-mark=C-Down_06 connection-state="" new-packet-mark=Down_06 passthrough=no
add action=mark-connection chain=forward connection-state=new new-connection-mark=C-Down_20 passthrough=yes src-address=
add action=mark-packet chain=forward connection-mark=C-Down_20 new-packet-mark=Down_20 passthrough=no

/interface pppoe-server server
add default-profile=At disabled=no interface=bridgeAT keepalive-timeout=15 one-session-per-host=yes service-name=S-PPPoE-C

/ppp secret
add name=00011 password=00011 profile=PPPoE_06Mbps/1Mbps service=pppoe
add name=00022 password=00022 profile=PPPoE_20Mbps/4Mbps service=pppoe

Re: PCQ Queue does not respect limits

Posted: Wed Jan 08, 2020 6:06 pm
by montiv
did you get to solved it? I´m having a similar problem :?

Re: PCQ Queue does not respect limits

Posted: Fri Feb 28, 2020 5:49 pm
by abernier
Not yet.

Re: PCQ Queue does not respect limits

Posted: Tue Jun 23, 2020 11:48 am
by ivicask
Got same problem, no matter what chain of mangle rules i set, prerouting,postrouting,forward, no matter what queues i try randomly some traffic just goes over limits and its not even properly detected by queues or its parents as you can see in example, parent queue should also show this traffic that child queue is using, but its not..
I have not set any bursts for parent queues or one that exceeds limit, so why this happens?