Community discussions

MUM Europe 2020
 
dancms
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Fri Oct 06, 2006 5:03 am

Bandwidth shaping among several users

Fri May 04, 2007 12:06 am

I have tried the PCQ setup that is in the documentation:

http://wiki.mikrotik.com/wiki/PCQ_Examples

I have had trouble with this so I have had to setup simple queues for my network.

On one segment I have over 2900 simple queues setup for clients and is getting hard to manage due to the number of ip's used and queues needed.

What I need is 1 rule instead of 2900 individual rules to set a max limit for every ip to a certain rate.

Example: set every IP in the range of 10.2.1.0/21 to a max limit of 256k down and 1000k up.

I belive PCQ "should" accomplish this if setup right.

Am I right?

Thanks,

Dan-
 
ptsip
newbie
Posts: 44
Joined: Fri Jan 20, 2006 7:17 pm

Fri May 04, 2007 5:10 am

A lot of useful tips and trick in forum, pls search in forum.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5972
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Fri May 04, 2007 6:11 pm

Yes PCQ will do the trick. As it was mentioned in previous post, search the forum, this topic was discussed many times.
 
dancms
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Fri Oct 06, 2006 5:03 am

Mon May 07, 2007 11:31 pm

Lets say I need to shape ip's 10.0.0.30 through 10.0.0.254.

When creating a rule I have to use x.x.x.x/24 . This shapes 254 addresses.

Then I need to create exclutions somehow for the first 30 ip's I do not want shaped.

Is there a way to specify an ip range instead of an subnet?

10.0.0.30-10.0.0.254 instead of 10.0.0.0/24.

Thanks,
dan
 
User avatar
Equis
Forum Veteran
Forum Veteran
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Tue May 08, 2007 10:44 am

Have a look at "address lists"

you can mark traffic etc
 
dancms
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Fri Oct 06, 2006 5:03 am

Tue May 08, 2007 5:18 pm

Will this work then?

ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=SHAPE-1 passthrough=no address-list=IP-RANGE-1

/queue type add name="PCQ_download" kind=pcq pcq-rate=64000 pcq-classifier=dst-address
/queue type add name="PCQ_upload" kind=pcq pcq-rate=32000 pcq-classifier=src-address

/queue tree add parent=global-in queue=PCQ_download packet-mark=SHAPE-1
/queue tree add parent=global-out queue=PCQ_upload packet-mark=SHAPE-1

Thanks,
 
dancms
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Fri Oct 06, 2006 5:03 am

Thu May 10, 2007 11:40 pm

Any ideas?

Who is online

Users browsing this forum: No registered users and 94 guests