Community discussions

MUM Europe 2020
 
ckgth
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 68
Joined: Wed Jun 06, 2007 5:03 pm

MPTS and SPTS forward in Bridge/CRS317

Mon Feb 10, 2020 5:25 pm

Hello,

i use an CRS317 with connect 2 IP Streams that steams many MPTS/SPTS via an CRS317 to an Multicast-Reciver.
On the CRS there are only the 3 Ports in a Bridge (2 from Streames, 1 to reciver). On The Switch on CRS ist also "port-forward override" to only the recice port so that the Streamers not recice the each other Streams.
All works fine. But now i will reduce traffic with IGMP for the SPTS Streams over the recive-port.
Now i have "ICMP snooping" enable on bridge an set the recive port
flood unknown broadcast and flood unknown unicast off.
It works, traffic for the SPTS forwar only, when i need it on recicer, but the traffic completly stops for 1-2sec on every 4-5 minutes (incl. the MPTS Streams) and streams not forward to reciver?!
Why? Have you any suggestion?

thank you
Christian
 
EdPa
MikroTik Support
MikroTik Support
Posts: 51
Joined: Fri Sep 15, 2017 10:05 am
Location: Riga
Contact:

Re: MPTS and SPTS forward in Bridge/CRS317

Tue Feb 11, 2020 9:26 am

It could be that the multicast group entry has timed out, by default membership-interval on the bridge is 4m20s.

When you want to correctly forward multicast traffic on a LAN network, there must be some IGMP querier who periodically sends IGMP query messages to keep the multicast databases up to date in switches. If there is no IGMP querier, the multicast entry will timeout. If you do not see any bridge ports with multicast-router=yes, then most likely there is no IGMP querier in the LAN, use a command "/interface bridge port monitor [find]". If this is the case, you can configure the switch to act as an IGMP querier (using the multicast-querier=yes option).
 
ckgth
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 68
Joined: Wed Jun 06, 2007 5:03 pm

Re: MPTS and SPTS forward in Bridge/CRS317

Tue Feb 11, 2020 11:51 am

Hi,

yes. Thank You. There ist no automatic "multicast-router=yes". I have set this Port manually to this, but not makes better. now i have set "multicast-querier=yes" and "multicast-router=yes on bridge. but these optiuons are only in cli, so that i have not seen this. thank you.
 
ckgth
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 68
Joined: Wed Jun 06, 2007 5:03 pm

Re: MPTS and SPTS forward in Bridge/CRS317

Tue Feb 11, 2020 12:24 pm

o.k.
i have set all 3 ports on bridge to "multicast-router=yes" an on bridge "permanent"
but the stream stops every 4mins...
 
EdPa
MikroTik Support
MikroTik Support
Posts: 51
Joined: Fri Sep 15, 2017 10:05 am
Location: Riga
Contact:

Re: MPTS and SPTS forward in Bridge/CRS317

Wed Feb 12, 2020 1:55 pm

With the current settings, can you simply disable/enable the igmp-snooping on the bridge interface and see whether multicast table still timeouts? Make sure the "multicast-querier=yes" is used.

Otherwise, please share your configuration and explain which bridge ports are used for multicast transmitter and receiver? Use command "/export hide-sensitive".
 
ckgth
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 68
Joined: Wed Jun 06, 2007 5:03 pm

Re: MPTS and SPTS forward in Bridge/CRS317

Wed Feb 12, 2020 4:42 pm

Hello,

i have set the igmp-snooping now after all sets:
settings now (last set was igmp-snooping=yes):

[admin@astro-multicast-switch1] /interface bridge> pr det
Flags: X - disabled, R - running
0 R name="bridge1" mtu=auto actual-mtu=1500 l2mtu=1592 arp=enabled arp-timeout=auto mac-address=0A:25:94:86:84:0E protocol-mode=none fast-forward=yes igmp-snooping=yes
multicast-router=permanent multicast-querier=yes startup-query-count=2 last-member-query-count=2 last-member-interval=1s membership-interval=4m20s querier-interval=4m15s
query-interval=2m5s query-response-interval=10s startup-query-interval=31s250ms igmp-version=2 auto-mac=no admin-mac=0A:25:94:86:84:0E ageing-time=5m vlan-filtering=no
dhcp-snooping=no
[admin@astro-multicast-switch1] /interface bridge> po pr det
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
0 H interface=sfp-sfpplus1-u159 bridge=bridge1 priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto learn=auto horizon=none hw=yes auto-isolate=no
restricted-role=no restricted-tcn=no pvid=1 frame-types=admit-all ingress-filtering=no unknown-unicast-flood=yes unknown-multicast-flood=no broadcast-flood=no
tag-stacking=no bpdu-guard=no trusted=no multicast-router=permanent fast-leave=no

1 H interface=sfp-sfpplus2-u148-s1-links bridge=bridge1 priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto learn=auto horizon=none hw=yes
auto-isolate=no restricted-role=no restricted-tcn=no pvid=1 frame-types=admit-all ingress-filtering=no unknown-unicast-flood=yes unknown-multicast-flood=no
broadcast-flood=no tag-stacking=no bpdu-guard=no trusted=no multicast-router=permanent fast-leave=no

2 H interface=sfp-sfpplus3-u148-s1-mitte bridge=bridge1 priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto learn=auto horizon=none hw=yes
auto-isolate=no restricted-role=no restricted-tcn=no pvid=1 frame-types=admit-all ingress-filtering=no unknown-unicast-flood=yes unknown-multicast-flood=no
broadcast-flood=no tag-stacking=no bpdu-guard=no trusted=no multicast-router=permanent fast-leave=no


It looks it work now.
Many Thanks.
But 1 Question: must i set multicast-router=permanent on all ports and on bridge? or only on stream-reciver-port(s) and not on steamer-ports and bridge? The "multicast-router" ist the next IGMP Switch or an IPTV Reciver?

Christian
 
EdPa
MikroTik Support
MikroTik Support
Posts: 51
Joined: Fri Sep 15, 2017 10:05 am
Location: Riga
Contact:

Re: MPTS and SPTS forward in Bridge/CRS317

Wed Feb 12, 2020 5:30 pm

In order to start the "multicast-querier", it looks like igmp-snooping should be disabled/enabled, we will try to improve this behavior so that it starts to work automatically.

A multicast-router port should be a port where a multicast router or other uplink IGMP Snooping bridges are connected. As I understood, you do not have any multicast routers (the traffic between receiver and transmitter is forwarded in the same LAN/VLAN) and there are no other IGMP Snooping bridges, so you actually do not have any multicast-router ports. I would recommend using the default "temporary-query" (auto) mode where the switch will listen on IGMP queries and automatically learns where any join messages should be forwarded. In case you need to strengthen your local multicast setup, e.g. from some malfunction clients that start to act as a multicast-router, you can disable the auto-learning.

See the documentation:
https://wiki.mikrotik.com/wiki/Manual:I ... t_Settings

Who is online

Users browsing this forum: Andrejm, Google [Bot] and 141 guests